LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 04-29-2004, 02:48 PM   #1
tomgreg2002
LQ Newbie
 
Registered: Apr 2004
Posts: 5

Rep: Reputation: 0
Question Redhat 9 nvidia nic install


Hello everyone....I am new to linux struggling to get my Nic going so I can get my cable
modem connected...
I am using Redhat9 with an AMD athlon XP + processor. kernal: 2.4.20-6.
I downloaded from nvidia the src.rpm: NVIDIA_nforce-1.0-0269.src.rpm
but when I attempt to build the rpm I get an error. I type in:

rpmbuild --rebuild NVIDIA_nforce-1.0-0269.src.rpm

It attempts to build but I get these errors at the end:

make[1]: *** [nvnet.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvnet'
make: *** [nvnet_make] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.96301 (%build)

RPM build errors:
user buildmeister does not exist - using root
user buildmeister does not exist - using root
user buildmeister does not exist - using root
user buildmeister does not exist - using root
user buildmeister does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.96301 (%build)


Any ideas? Please help a disgusted windows user that wants to become a Linux guy!!!
Thanks a lot. - T
 
Old 04-29-2004, 10:08 PM   #2
tomgreg2002
LQ Newbie
 
Registered: Apr 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Hello. I also tried installing from a tar file. When I
ran make I got the following....

make -C nvnet
make[1]: Entering directory `/home/thomas/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.20-6/build/include -DMODVERSIONS -include /lib/modules/2.4.20-6/build/include/linux/modversions.h nvnet.c
ld -r -o temp.o nvnet.o nvnetlib.o
nvnetlib.o: file not recognized: File format not recognized
make[1]: *** [nvnet.o] Error 1
make[1]: Leaving directory `/home/thomas/nforce/nvnet'
make: *** [nvnet_make] Error 2

Any ideas? Please assist..thanks. ---T
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fail to install NIC on Redhat 9 noelcantona Linux - Hardware 6 12-01-2004 06:55 PM
wireless nic install redhat 9.0 jonasmit Linux - Wireless Networking 0 07-30-2003 08:22 PM
Trying to install drivers for Linksys WUSB11 NIC v2.5 on RedHat 9 Golbez Linux - Newbie 5 04-08-2003 02:46 PM
Need help with NIC install on Redhat 7.2 ?? admy Linux - General 1 11-21-2002 01:47 PM
RedHat 7.3 Install ? (NIC Card and X Server) rshadow Linux - Hardware 2 09-29-2002 07:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 06:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration