-   Linux - Distributions (
-   -   Red Hat RPMs vs Mandrake RPMs (

pioniere 02-26-2003 01:13 PM

Red Hat RPMs vs Mandrake RPMs
Is it possible to use Mandrake RPMs for Red Hat where no Red Hat RPMs exist, and vice-versa? Any special command line options needed? Thanks.

randyennis 02-26-2003 01:31 PM

Yes, it's possible (I've done it a few times). It's not a desirable thing to do, because of the dependencies, but possible! What I would recommend is that you try to install the package (rpm -ivh 'packagename' ) and see what dependency issues arise. Check your installation (rpm -qa | grep 'dependency' ) to see if you actually do have the necessary Red Hat specific installation(s). If not, install as much as you can from your Red Hat sources. Then you can install the Mandrake package using rpm -ivh --nodeps 'packagename'.

If you haven't done it, I'd recommend looking at to be certain there are no Red Hat rpms available. You could run into trouble where software loaded from Mandrake rpms may be compiled using another version of gcc, which may make them 'unrunnable' on your Red Hat system. Get as much specific information about your system and the new rpms as you can!

pioniere 02-26-2003 08:30 PM

Thanks for the info. I looked on rpmfind, but there were no Red Hat RPMs for the package I was looking for, only Mandrake and others. Thanks again.

boonders 02-27-2003 02:22 AM

so what are you looking for...and of course this begs the question...why not give mandrake a try? :D
do you have synaptic installed? that is great for dependencies and different software for RedHat.(mplayer, xmms MP3 support, etc.) without the hassle, and it'll update your system for FREE! :) not as quick as the Redhat up2date thingy but, within 24 hours. TRY MANDRAKE :)

pioniere 02-27-2003 12:38 PM

Actually, I've tried Mandrake at home. 8.x worked great, 9.0 was disappointing since it was a troublesome install on my garden variety Dell. The RedHat RPM question was work related :)

All times are GMT -5. The time now is 09:45 PM.