-   Linux - Distributions (
-   -   recording/capturing audio (

gymnart 09-24-2006 10:38 AM

recording/capturing audio
I would like to record or capture audio and I've read a bit about using the AlsaMixer. I tried the settings suggested but when I click on the record button in Audacity, I get the following message (while I'm playing the music I would like to record):

"Error initializing audio i/o layer. You will not be able to play or record audio. Host error"

I also get the message:

"Error while opening sound device. Please check the input device settings and the project sample rate."

I've seen that the input device is /dev/dsp and there are no other choices. it's the same as the playback device.

In AlsaMixer, it says that it is set to Capture All.

I'm using SuSE 10.0

Brian1 09-24-2006 10:57 AM

If you wish to record a continues long mp3 type file then check out the simply script mp3record.

If you are trying to record streaming audio and have it devide into seperate songs then check out streamtuner.
Or streamripper


gymnart 09-24-2006 11:14 AM

I wanted to record the sound from a video that I was watching. Would this work in mp3record also?

Brian1 09-24-2006 11:46 AM

mp3record should do the trick. It just stores it as mp3. Open the mp3record file and read up on the commands inside it.


gymnart 09-24-2006 12:19 PM

I just tried it out and i was not happy with it.

I had to be root to record anything and I could not play any files as a user.

It was installed in /usr/bin. I have now uninstalled it.

Can it be made so that it can be used as any user or is there something I'm missing?

Brian1 09-24-2006 02:57 PM

No problems here as a user. I just extracted to my local home directory and run ./mp3record. Only thing you may need to do is set the permissions on /dev/dsp. Set to like ' /sbin/chmod 666 /dev/dsp '.


gymnart 09-25-2006 10:45 AM

I did extract it to my home directory but when I type in a terminal ./mp3record, it says that it is a directory.
The directions that were included in the package said:

To install mp3record, simply run the included as root
$ cd /whereyouunzippedit/mp3record/
$ ./

Which is what I did but what I did not understand completely was:

"sox and lame need to be installed and in the $PATH variable." I know I have sox and lame but what do they mean by $PATH variable? They did not show an example of that.

Also when I tried (as root) /sbin/chmod 666 /dev/dsp it said no such file or directory.

Brian1 09-25-2006 03:58 PM

$PATH is used to define path variables. When you type the command ' $PATH ' it will show the directories used in path. So all you need to do is verify that say if lame is at /usr/bin/lame that one of the path variables is /usr/bin.

My fault the chmod command is in /bin and not /sbin. I just perfer to use full path to commands so there is no issues when one uses su or su -.


gymnart 01-05-2007 08:37 PM

When I had sound problems after an update, I had my husband install a soundcard that we had laying around and I installed the newest Alsa sound driver.
I just tried to record from the internet radio today and found that I can now capture sound.

I guess all it took was to have a soundcard installed rather than trying to use the "onboard" sound that comes on the motherboard.

All times are GMT -5. The time now is 08:16 PM.