-   Linux - Distributions (
-   -   Problem running salix (

linuxlover2 05-23-2011 06:50 PM

Problem running salix
I installed Salix 13.37. I installed it on an external hard drive and my laptop is a dell inspiron 1540 with an intel pentium. I installed the default kernel hugesmp.s. I ran the autoinstall option dedicating my entire external to salix. When it restarted, LILO loaded and I chose linux (trying to dual boot with windows) and then it put up BIOS data check successful followed by:

[7.148184]kernel panic-not syncing: VFS: unable to mount root fs on unknown-block
[7.148184]Pid:1, comm: swapper Not tainted
[7.148296] Call Trace:
[7.148349][<c19daa01>] ?printk+0x1d/0x1f
[7.148401][<c19da8f3>] panic+0x5d/0x14d
[7.148453][<c1cfac39>] mount_block_root+0x1c0/0x259

And it continues in that fashion for a few more lines. BTW, I did try installing the other kernel option of huge.s but I got the same result. Any help that you can give me will be greatly appreciated. Thank you in advance.

Peacedog 05-23-2011 08:25 PM

Hi linuxlover2, Welcome to LQ. One of two things come to mind. Either Lilo isn't configured correctly or you don't have file system support built into your kernel. Options to correct this would be booting to a live disc and reconfiguring Lilo, rebuilding the kernel with support for your file system or creating an initrd to load the module at boot. I would start here.

Make sure Lilo is pointed at the correct partition.

Good luck. ;-)

All times are GMT -5. The time now is 09:55 AM.