LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Problem emerging KDE in Gentoo (https://www.linuxquestions.org/questions/linux-distributions-5/problem-emerging-kde-in-gentoo-323977/)

cdavidson 05-16-2005 07:38 AM

Problem emerging KDE in Gentoo
 
I just got X successfully installed on my first Gentoo install. Naturally, my next move was to install a desktop environment. My problem came about wile trying to emerge KDE. I issued this command:
Code:

emerge kdebase kdeadmin kdenetwork kdemultimedia kdeartwork
and I get this error:
Code:

checking for correct ltmain.sh version... no

*** Gentoo sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.16, ltmain.sh = 1.5) ***

Please run:

  libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.


!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/lcms-1.13/work/lcms-1.13/config.log

!!! ERROR: media-libs/lcms-1.13 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message. v

When I run libtoolize --copy --force like the error message says, I get:
Code:

libtoolize: `configure.ac' does not exist
Try `libtoolize --help' for more information.

I'm brand new to Gentoo and this one has got me stumped. I found this article in the Gentoo forums, but I can't figure what file they are talking about editing. This is apparently a known bug in Gentoo, but I haven't been able to find a clear answer as to how to fix it. Thanks in advance.

mrcheeks 05-16-2005 07:48 AM

Hi ,

They are talking about the ebuild files in portage. for example to emerge kdebase, go to the kdebase portage directory and edit the ebuild file to replace
Code:

elibtoolize
by
Code:

libtoolize --copy --force
.

Regards

cdavidson 05-16-2005 08:10 AM

Thanks for the quick reply. I'm at work right now. When I get home I will give it a try and post my results.

cdavidson 05-16-2005 12:04 PM

I don't see the text that I am supposed to edit anywhere. These are the files inside /usr/portage/kde-base/kdebase:
Code:

tux kdebase # ls -l /usr/portage/kde-base/kdebase
total 68
-rw-r--r--  1 portage portage 35019 May 11 20:05 ChangeLog
-rw-r--r--  1 portage portage  2437 May 11 20:05 Manifest
drwxr-xr-x  5 portage portage  4096 May 13 00:06 files
-rw-r--r--  1 portage portage  3476 Jan 17 16:07 kdebase-3.2.3-r3.ebuild
-rw-r--r--  1 portage portage  3843 Feb 22 02:38 kdebase-3.3.2-r1.ebuild
-rw-r--r--  1 portage portage  3630 May  9 00:06 kdebase-3.3.2-r2.ebuild
-rw-r--r--  1 portage portage  3639 May 11 19:57 kdebase-3.4.0-r1.ebuild
-rw-r--r--  1 portage portage  3470 May 10 16:05 kdebase-3.4.0.ebuild
-rw-r--r--  1 portage portage  156 Apr  5 16:05 metadata.xml

I've looked through each of the .ebuild files and they all look pretty much the same. There is no elibtoolize option under src_compile. This is my kdebase-3.4.0.ebuild file:
Code:

tux kdebase # cat kdebase-3.4.0.ebuild
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.4.0.ebuild,v 1.5 2005/05/10 15:46:26 carlo Exp $

inherit kde-dist eutils

DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."

KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~ia64"
IUSE="arts cups java ldap ieee1394 hal lm_sensors logitech-mouse opengl pam sambassl"
# hal: enables hal backend for 'media:' ioslave

DEPEND="arts? ( ~kde-base/arts-${PV} )
        pam? ( kde-base/kdebase-pam )
        >=dev-libs/cyrus-sasl-2
        ldap? ( >=net-nds/openldap-2 )
        cups? ( net-print/cups )
        ssl? ( dev-libs/openssl )
        opengl? ( virtual/opengl )
        samba? ( >=net-fs/samba-3.0.4 )
        lm_sensors? ( sys-apps/lm_sensors )
        logitech-mouse? ( >=dev-libs/libusb-0.1.10a )
        ieee1394? ( sys-libs/libraw1394 )
        hal? ( =sys-apps/dbus-0.23*
              =sys-apps/hal-0.4* )"

RDEPEND="${DEPEND}
        java? ( || ( virtual/jdk virtual/jre ) )
        sys-apps/eject"

src_unpack() {
        kde_src_unpack

        epatch ${FILESDIR}/${P}-startkde-gentoo.patch
}

src_compile() {
        myconf="--with-dpms"
        myconf="${myconf} $(use_with arts)"
        myconf="${myconf} $(use_with ldap) $(use_with cups)"
        myconf="${myconf} $(use_with opengl gl) $(use_with ssl)"
        myconf="${myconf} $(use_with hal)"

        use pam && myconf="${myconf} --with-pam=yes" \
                || myconf="${myconf} --with-pam=no --with-shadow"

        # the java test is problematic (see kde bug 100729) and
        # useless. All that's needed for java applets to work is
        # to have the 'java' executable in PATH.
        myconf="${myconf} --without-java"

        kde_src_compile
}

src_install() {
        kde_src_install
        cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install

        # startup and shutdown scripts
        insinto ${KDEDIR}/env
        insopts -m 644
        doins ${FILESDIR}/agent-startup.sh

        insinto ${KDEDIR}/shutdown
        insopts -m 755
        doins ${FILESDIR}/agent-shutdown.sh

        # x11 session script
        cat <<EOF > ${T}/kde-${SLOT}
#!/bin/sh
exec ${KDEDIR}/bin/startkde
EOF
        exeinto /etc/X11/Sessions
        doexe ${T}/kde-${SLOT}

        # Create a kde.desktop file for freedesktop-compliant login managers
        sed -e "s:_PREFIX_:${KDEDIR}:" \
            -e "s:_VERSION_:${SLOT}:" \
                ${FILESDIR}/kde.desktop > ${T}/kde-${SLOT}.desktop
        insinto /usr/share/xsessions
        doins ${T}/kde-${SLOT}.desktop

        # Customize the kdmrc configuration
        sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
              -e "s:#GreetFont=:GreetFont=Sans Serif,24,-1,5,50,0,0,0,0,0\n#GreetFont=:" \
              -e "s:#StdFont=:StdFont=Sans Serif,12,-1,5,50,0,0,0,0,0\n#StdFont=:" \
              -e "s:#FailFont=:FailFont=Sans Serif,12,-1,5,75,0,0,0,0,0\n#FailFont=:" \
              -e "s:#AntiAliasing=:AntiAliasing=true\n#AntiAliasing=:" \
                ${D}/${KDEDIR}/share/config/kdm/kdmrc || die

        rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
}

pkg_postinst() {
        # set the default kdm face icon if it's not already set by the system admin
        if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon" ]; then
                mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
                cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/default1.png" \
                        "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon"
        fi

        mkdir -p ${ROOT}${KDEDIR}/share/templates/.source/emptydir

        echo
        einfo "To enable gpg-agent and/or ssh-agent in KDE sessions,"
        einfo "edit ${KDEDIR}/env/agent-startup.sh and"
        einfo "${KDEDIR}/shutdown/agent-shutdown.sh"
        echo
}

Am I looking at the right .ebuild file?

mrcheeks 05-18-2005 03:01 PM

You have to figure out which ebuild is used. When you try to emerge which version does it suggest? Check the version and edit the corresponding ebuild. You can try to add
Code:

libtoolize --copy --force
if
Code:

elibtoolize
is not present in the section src_compile() of your ebuild file. I am not sure it will work though, but it won't hurt to try.

kansho 05-27-2005 07:59 PM

i gopt the same error emerging mozilla-firefox for blackbox..... i did a emerge sync and that fixed it duno if that will help you or not


All times are GMT -5. The time now is 02:18 AM.