LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Philips USB webcam doesn't work on Suse 9.1 (https://www.linuxquestions.org/questions/linux-distributions-5/philips-usb-webcam-doesnt-work-on-suse-9-1-a-201502/)

Haldrik 07-05-2004 07:39 PM

Philips USB webcam doesn't work on Suse 9.1
 
Hello Everyone:
Just installed Suse 9.1 and am having problems getting my Vesta Pro camera (Philips) USB working. USB works in general for printer, CompacFlash card reader, etc.
The camera usually works with the module pwc and pwcx , but I believe the kernel has built in support at this point.
The Yast Hardware Information function lists the device and lots of info about it, including the fact that it is using the pwc "driver" . Some possibly important info from this screen is:
Bus: USB
Class: Camera
Device identifyer 197384
Device: PCVC680K WebCam [pwc]
Vendor: Philips
bus_hwcfg: usb
hotplug: usb
sysfs_bus_id: 2-2:1.0

However, no programs are able to access the /dev/video0 device (have tried camstream, gnomemeeting).
When plugging in the camera, the following message appears in /var/log/messages:


Jul 5 19:32:15 linux kernel: usb 2-2: new full speed USB device using address 4
Jul 5 19:32:15 linux kernel: usb 2-2: SerialNumber: 021302112010465A
Jul 5 19:32:15 linux /etc/hotplug/usb.agent[6084]: need a device for this command
Jul 5 19:32:15 linux /etc/hotplug/usb.agent[6083]: need a device for this command
Jul 5 19:32:17 linux /etc/hotplug/usb.agent[6152]: need a device for this command

Back in Mandrake 9.0 , you had to add a line in modules.conf to force the pwcx module to load after the pwc one, but like I said, I can't even find a pwc.o file , and insmod pwc causes a fatal error, with no such module being found.

Any ideas about what is wrong here???

Thanks!

Haldrik 07-09-2004 11:01 AM

Well, after much searching, I've found the solution to my own problem, which I will post here:

The kernel in Suse 9.1 doesn't have the pwc module built in, so you have to install the kernel sources. Then:

In the /usr/src/linux/drivers/usb/media folder you have to edit the Kconfig file to remove "&& BROKEN" from line 111 of the file (line starts with "depends on USB && VIDEO_DEV && BROKEN").

Issue the following commands (as root):
zcat /proc/config.gz > /usr/src/linux/.config
cd /usr/src/linux/
make xconfig

In the Xconfig program, go to Devices, then USB and you will see the Philips Webcam option: select the device and save configuration.

Then issue this command:

make modules modules_install

That's it!

Cossack 08-11-2004 05:45 PM

Anyone got the pwcx module to load
 
After following Haldrik's instructions, I built the pwc 9.02 module, then applied the patch and built pwcx 9.0 as per instructions on the philips webcam page:

http://www.smcc.demon.nl/webcam/

After rebooting, the pwc module loads fine, but I can't load the pwcx module. I get an 'invalid parameters' error on attempting to insert the pwcx module. dmesg tells me that the module versions don't match: I have pwc 8* loaded. I have rebuilt the module with 9.02 source and yet still get this error.

Anyone had and better luck? Any suggestions?

Cheers,

Cossack.


All times are GMT -5. The time now is 04:17 PM.