-   Linux - Distributions (
-   -   (Partly Solved) Need help with remix of TinyCore. (

nooby 02-06-2011 11:47 AM

(Solved) Need help with remix of TinyCore.
Newest edit. RobertS have no released 3.7 RC3 and that one do almost everything this remix did so now one can install TinyCore on NTFS and have both read and write and that was only working on the remix before. So solved

old edit
Edit after some 12 hours of headache and lost work again and again. This distro is too difficult for someone as ADHD as I am.

I need to learn more first. I am too early in the learning curve so it is fruitless because I forget all advice too fast. But I ahve two versions of TCL now. One Remix version by SvOlli and the original TCL341 that is the official one but that one only works on Fat32 or Ext2 and I have fat32 on the USB but NTFS on the HDD so it fail to boot up there.

The remix has NTFS-3g installed so it can boot and read and write on HDD.

My older text follows

I fail to get Alsa sound most likely using VLC on Tinycore. It does show the videos but no sound. No sound on youtube either so could be a general activation of sound thing. I know too little.

Because I use a nonofficial version of TC they have rules that they don't want one ask about them on their forum. So Hope I find People here that could be of help. How did you get sound using TCL?

I am using it now on Firefox so I love it because it even play streaming video using getFlashplugin from our TV station but no sound.

rokytnji 02-06-2011 11:55 AM

Have you installed latest adobe in tinycore /usr/lib/mozilla/plugins folder?

I don't run tinycore nooby. So I won't be of much help. I don't use VLC either in Puppy but use Gnome Mplayer or Gxine instead. Can You post a link of what won't play so I can test in my Puppy 5.2 to see if it does the same?

nooby 02-06-2011 12:17 PM


Originally Posted by rokytnji (Post 4250103)
Have you installed latest adobe in tinycore /usr/lib/mozilla/plugins folder?

I don't run tinycore nooby. So I won't be of much help. I don't use VLC either in Puppy but use Gnome Mplayer or Gxine instead. Can You post a link of what won't play so I can test in my Puppy 5.2 to see if it does the same?

You sure are a kind person. Jay thanks for responding. Luckily I managed to find the answer on the TC wiki so I have sound now on VLC have not tested on youtube yet. Hold your breath while I go to your tube :)


Yes! sound there too. I am a lucky man indeed. But I have no idea how I got sound. First I tried their

sudo alsaconfig but that did not work at all. Then I tried everything in the book and most likely it was the long thing one had to start alsa by giving a absolute path to the program and that started the alsa thing.

So now I only lack a picture viewer for TC. The one they recommended are too primitive. One need to feed it manually which files one want to see one by one and then one can see all of them . Usually Viewnior and such show next picture in a Dir if one do Pause or > or somethign. But I am lucky to have and even ha ha I know no French but they have i that has two dots. Surprisingly it can not do AltGr which Puppy and AntiX do.

What I still have not done is setting up Iptables because I have no idea how one do it. Rea the wiki they would tell me. But I never understand such high level tech texts.

Anyway I should.
It is 7PM here what time do you have locally there in USA? Is it still snowing?

rokytnji 02-08-2011 07:32 AM

Snow Tomorrow. 78F here today on my Birthday. Gonna treat myself all day to tasty goodies.

I am 7 hours different than you in Sweden.Don't they have a gui like Firestarter GUFW.

In case you don't have this.

command for looking at firewall is


sudo iptables -L


There is no firewall "program" that runs. iptables firewalling happens in the kernel. you can see the firewall rules that have been set by the basic script by running "sudo iptables -L" from a terminal
So no Firestarter or GUFW I guess.

Thread I found.

nooby 02-08-2011 08:51 AM

I always think that I find a cli code again I am too impatient to write it down. And even when I do it end up in a binge of such notations and I have no idea what they are for.

Thanks for the links. I finally got IPtables set up then lost it and managed to get it again but it took me some 12 hours.

I know too little to make use of TCL one should be a linux geek to love that distro.

But it reminds me of when we all??? had Ms-DOS and 8086 and 80186 and 80186 and 286 :) We did a lot in CLI then and I was the one that was the last to remember and had to ask the other guys how one do simple things and they got fed up with all my questions. I understand them. I am a PITA not knowing enough to get around.

Thanks for being there for me.

aus9 04-30-2011 10:33 PM


you can see what a basic firewall is by reading the info file as per

Title: iptables.tcz
Description: Firewall (userspace part)
Version: 1.4.10
Author: Various
Copying-policy: GPL
Size: 404K
Extension_by: Curaga
Comments: Iptables is the userspace tool to control
the linux kernel firewall. A simple script
included, suitable for home users.
From a terminal:
sudo /usr/local/sbin/basic-firewall
From (to start on every boot):
/usr/local/sbin/basic-firewall noprompt
PPI compatible
Change-log: 2008/10/28 Original
2009/04/30 Update to
2010/11/10 Added a noprompt option to basic-firewall
Current: 2010/12/14 Update to 1.4.10

as found here

click on iptables.tcz info link

2) I know you have not posted for awhile but do you use grub2 by any chance?

and what is your main hard drive linux distro?

nooby 05-01-2011 06:00 AM

Thanks aus9. You ask me

"2) I know you have not posted for awhile but do you use grub2 by any chance?

and what is your main hard drive linux distro?"

Depends on what one refers to as using. I got a friendly gift from member rcrsn51 on Puppy Forum he made a puppy version of Pendrive Linux grub2 for USB so when I want to test a Grub2 distro that fails to boot frugally on my NTFS HDD which have a Puppy Linux distro as the main linux that I use now and always if I am not trying out something I read about on DW.

So I am using a frugally installed Snowpuppy 5 booting grub4DOS daily and grub2 on USB only when I want to test Peppermint or some other Debian or Ubuntu or whatever version that want a grub2 boot.

Grub2 installed on USB flash allowed me to boot Peppermint latest, Ubuntu 11.04, WattOS PureOS, and one more that I now forgot about.

I want to test Arch too and Gentoo but I am not that intelligent most likely.

Porteus I thought needed grub2 to boot on NTFS hdd but that was not the case. One only needed to edit out all the specifics from the kernel line and it booted up just like that. No sweat at all. And I spent many many hours on it January and failed to make it let me have access to my youtube video clips so I gave up on it but look how easy it is here

title Porteus OS
rootnoverify (hd0,0)
kernel (hd0,0)/boot/vmlinuz /dev/sda1/porteus
initrd (hd0,0)/boot/initrd.lz

Take the iso and use puppy and click on it to mount it and make a copy of the two directories on the mnt/home one named boot and the other named porteus

Then just reboot and and it just works. Wish I had known this in January that had spared me much frustration and feeling bad about my failure to boot it.

Thanks for caring about me. The reason I seldom post here is that I almost always get no reply or only a reminder that I done something wrong so it is not easy to maintain motivation to post.

aus9 05-19-2011 05:12 PM

okey dokey

1) I don't like Puppy or puplets as they tend to run in root mode only
I tried one puplet and the blinking thing formatted as inode 128 on me

2) roberts discusses ntfs here

as you may see ext4 is an issue

but I recommend ext3 so not an issue for me.

3) is that typo I see or a true copy and paste?
initrd (hd0,0)/boot/initrd.lz

try initrd.gz

4) I rarely post here as well.....if you have further questions etc better off to send me a pm which is mailed to me ok?

All times are GMT -5. The time now is 09:32 PM.