LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 05-17-2003, 10:45 AM   #1
robert837
LQ Newbie
 
Registered: May 2003
Distribution: Lycoris Desktop L/X
Posts: 5

Rep: Reputation: 0
Onboard SiS 650 video chipset Won't work in Lycoris. please help!


My SiS 650 onboard video. won't work. every time i start lycoris desktop l/x it goes to video rescue mode. my SiS 650 isn't on the list of devices in lycoris. i have downloaded new drivers for it but do not know how to install them, and if i install them will it work. i am a real newb,only installed yesterday. pls help thanx.


also KDE crashes about15 seconds of browsing my files!
 
Old 05-17-2003, 12:32 PM   #2
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
my suggestion is to install the drivers... and edit your XF86config...
 
Old 05-17-2003, 02:09 PM   #3
robert837
LQ Newbie
 
Registered: May 2003
Distribution: Lycoris Desktop L/X
Posts: 5

Original Poster
Rep: Reputation: 0
cheers jt1020

But could you please explain how i can do these two things.

i thought being good at windows would mean i wouldn't find linux that difficult - boy i was wrong!
 
Old 05-17-2003, 02:27 PM   #4
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
First make sure that your drivers are for Linux... if not, ask for your manufacturer if they have drivers for Linux...

I'm pretty sure that your driver will have a readme or installation instructions...

You can edit your XF8config by using any editing program... for example: gedit XF8config.... you must be root to edit your XF8config...
 
Old 05-18-2003, 05:54 PM   #5
Mork
Member
 
Registered: Mar 2003
Location: Visby, Sweden
Distribution: Ubuntu 4.10
Posts: 64

Rep: Reputation: 15
I too have a SiS 650; being lazy I simply use the generic vesa device, which works fine. You can probably select it at install-time or configure X by running xf86config as root (you need to know max resolution for the monitor, and the HorizSync and VertRefresh, if your lucky you have a manual with this information). It should be possible to get the real sis-driver with xf86config, if I remember correctly there is a driver for sis315 that might work.

Check this page:
http://www.winischhofer.net/linuxsis630.shtml

Oh, and hang in there - it gets easier
 
Old 05-19-2003, 06:05 AM   #6
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
Quote:
Originally posted by Mork
Oh, and hang in there - it gets easier
True....
Good Advice...
 
Old 05-19-2003, 12:53 PM   #7
robert837
LQ Newbie
 
Registered: May 2003
Distribution: Lycoris Desktop L/X
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks Guys. I'll try it.
 
Old 05-20-2003, 11:15 AM   #8
robert837
LQ Newbie
 
Registered: May 2003
Distribution: Lycoris Desktop L/X
Posts: 5

Original Poster
Rep: Reputation: 0
Smile

Cheers everyone who tried to help.
Mork , your suggestion worked fine,and for everyone out there with an emachines 555/755 from PCWorld, here are the settings you need:

Video Card: Generic VESA

Monitor: typical monitors
1024x768 17Inches
Horiz. freq. 30-86

Screen resolution: 1024x768
70hz
colour depth 16

These should work for everyone with a Proview EN-171 17 inch monitor and possibly (according to the manual the settings are basically the same) the EN-151 too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sis 530 onboard video problems spctrkr Linux - Hardware 5 12-06-2004 09:48 PM
onboard-sound @ lycoris doesn't work ungua Linux - Hardware 0 10-11-2004 05:07 AM
SIS 300 video onboard MDK 9.1 vermeersch Linux - Hardware 1 09-09-2003 06:04 AM
sis 650 video.... thedraphter Linux - Newbie 2 08-14-2003 03:26 PM
SiS 650 doesnt want to work in Lycoris robert837 Linux - Newbie 0 05-16-2003 03:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 04:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration