-   Linux - Distributions (
-   -   NVIDIA GeForce FX Go5200 & Suse 9.0, 3D graphics thing won't work! (

mawooshen 05-09-2004 01:34 PM

NVIDIA GeForce FX Go5200 & Suse 9.0, 3D graphics thing won't work!

installed Suse 9.0 a month ago and still don't seem to have it working like is should!

Latest problem is the NVIDIA graphics card driver. Used YOU to download and install the driver like the NVIDIA website said but the 3D acceleration stuff is still disabled... There was some notes in the readme saying that some older Suse versions would have an error saying that 3D was disabled but that you should ignore it and it would work all the same.

Unfortunately it's not working, when I try and run the Armagetron game that comes with Suse, it says that there is no 3D card and then it crashes...

Can anyone help me?


Andrew Benton 05-09-2004 04:07 PM

Have you tried editing /etc/X11/XF86Config ? in the section "Module", uncoment the line
# Load "glx"
so it reads
Load "glx"

mawooshen 05-09-2004 06:15 PM

Thanks for the suggestion, the NVIDIA site mentioned the XF86Config file as well but I checked it and the Load "glx" is there... but still not working...

squid69 05-10-2004 04:12 PM

Go to YOU,update driver only,go into terminal as root type "init 3"
when into this get into root mode and type "sax2 -m o=nvidia" 0 is number not letter
when you get into sax2,edit config, go to 3d thingy and enable 3d and save
It should load up with nvidia logo before desktop loads

hope all works sorry its pretty vague but its pretty self explanatry
:newbie: :Pengy:

mawooshen 05-11-2004 06:35 PM


thanks squid69, I'll try that just as soon as I work out how to get my mouse working again! Like an idiot I re-configured my mouse to try and get the wheel to work and now can't use the mouse at all!...

you don't know how to configure the mouse from the failsafe mode do you?! It's a microsoft Wheel Mouse Optical USB and PS/2 Compatible with Left Right buttons and Middle wheel/button. Do you know if there are any keyboard shortcuts that I could use in KDE to get to Yast?

Maybe I should start another thread!...

mawooshen 05-11-2004 07:41 PM

Okay worked out the keyboard shortcuts and mouse (although without wheel) is working again, so back to Nvidia...

mawooshen 05-11-2004 08:14 PM

Okay, working at last! Thanks a lot, any chance you could explain what it was I just did?!...

squid69 05-12-2004 01:10 PM

With suse the 3d wont work unless you do the above but this even includes 9.1 even though when you install it say`s 3d is enabled you still have to go to init 3 to save it.

You have just exited the X86 gui (I think) and enabled 3d in text mode through sax2 ?

Got it.................................No me neither

mawooshen 05-12-2004 03:40 PM


All times are GMT -5. The time now is 06:10 AM.