-   Linux - Distributions (
-   -   No distros seem to work on my computer..please help. (

gejr 03-19-2007 06:03 PM

No distros seem to work on my computer..please help.
Thanks for reading through this post. I'm a below average experienced linux user.

I've ran Ubuntu successfully for a while on my laptop. About time I install some funky distro on my main desktop computer too I thought. So I've spent the last 4-5 days downloading and trying to install different distros, but none of them seem to work.

I've tried these:

- OpenSuse10.2. and I get kernel panic and never even see any options.

- SimpleMepis6.5 RC2/RC1 gives me /etc/init: /etc/init: 5 /linuxrc: not found. I can't seem to get past this one. I've tried all the options in the menu.

- Mandriva 2007: No CDROM found, and I can't seem to install by any other ways either. I tried directing it to the windows partition where the .iso still is, but got some kinda kernel error and system froze.

- Ubuntu: This distro that has worked so wonderfully on my laptop doesn't even work on my desktop comp. It didn't find any screens afaik.

- Sabayon newest DVD: Can't find any screens and running it with vesa driver doesn't even work.

Other distros I've tried: PCLinuxOS, Linux Mint (Ubuntu derivate) and GenToo.

So..all these distros to no avail. What can you guys give me of tips? I really want to run something linuxy on this machine to learn more about linux networking.

Please..any suggestions are welcome.

My specs could also be of importance here. I think my computer is more on the fresh side. I have:

- Asus P5B-E Motherboard
- 2 Gb memory
- Intel Core 2 Duo 2,13Ghz
- XFX GeForce 8800GTS
- 1 IDE disk and 2 SATA disks

drewbug01 03-19-2007 06:08 PM

have you tried knoppix? i've heard hardware detection is good on that.

Brian1 03-19-2007 06:15 PM

Just an idea for the screen issue. Maybe find a cheap video card or borrow one from a friend. See if Ubuntu installs then. Then if it installs then install nvidia drivers for linux and setup xorg.conf file and swap cards. Keep a backup of a working incase you may need to modify.


gejr 03-19-2007 06:28 PM

I've tried Knoppix too yea..I got some kind of error there too. I think it was another kernel panic before I even got the menus up. There's something seriously wrong with my hardware. And how can Mandriva say it doesnt find the cdrom when I just booted from that very cdrom.

I have a XFX GeForce 6800GS laying around, maybe I'll try inserting that. But it's pretty much the same I guess. Anyways, thanks for the tip.

dxqcanada 03-19-2007 06:39 PM

Ummm, I hate to ask but ... does Windows install ok on this hardware??

Did you run the Gentoo LiveCD with the nox boot option ??

2damncommon 03-19-2007 09:48 PM


So I've spent the last 4-5 days downloading and trying to install different distros, but none of them seem to work.
As you can see, throwing distros willy nilly is not always the answer. I would suggest picking one (okay, or two) and following up on the error codes. Is the problem disks burned at too high a speed, problem hardware, needed boot commands missing? Find what works best and focus on the real issues.
Have you tried live CDs in the failsafe mode?

gejr 03-20-2007 02:59 AM

Yes, Windows installs well on this hardware.
You're probably right, 2damncommon. Just throwing distro at it doesn't seem to be the best approach.
I think I'd like to focus on Sabayon. I'm curious about that one. It's one of the distros that at least gets me to a command console. I'm trying to install it as I write this to give most up2date errorlog. I chose GUI installation as that is what I'd prefer, but no worries, I've tried all options on that menu.

A splash screen appears, loading different stuff obviously. I get a little error message on top of the splash stating that something's wrong with "nvidia.ko".
The loading is complete, the beautiful splash is mostly gone. It is replaced by a common linux console covering most of the screen, so much for the GUI-installation:
No errors as far as I can see. Latest info is:
-Starting sshd [ok]
-Sabayon Linux Text Installer service not enabled [ok]
sabayonx86 root#

I run dmesg | less to see if there's anything particular sticking out and it's so full of crap that I don't understad. Doesn't seem like the big errors though..a few ACPI interrupts about something to do with different IRQs..maybe I should disable APCI somehow.

Anyways..during boot it complained about that nvidia.ko, so setting the driver to "vesa" in /etc/X11/xorg.conf would be my next attempt I guess.

Ok, mission complete. Question is, where to go from here? I can now type "startx" and a weird window manager appears. It's opened 2-3 xterms and a analog clock is visible in the top right corner. This is most definately not the common Gnome or KDE. A left click (yes, actually) on the desktop uncovers a menu with the header "TWM". Not really the biggest help there. And no install icon on the desktop as I'm used to with other distros. I do a CTRL+ALT+F1.

Back in the console I see:
- (EE) Failed to initialize GLX extension (Compatble NVIDIA X driver not found)
Thought I had disabled this when I replaced nvidia with the "vesa" driver. Must have overlooked something.

I ctrl-C to kill the running X session.

startkde - after some promising text the screen gets full of these:
- kwin: cannot connect to X server
- kpersonalizer: cannot connect to X server.

Doh..I thought I just was in an X session with that TWM stuff.

startxfce4 gives me a beautiful xfce4 session, but no install icon on the desktop, so I have no idea what to do.

What would be my next approach on this distro?

Thanks for reading through these rantings on installing Sabayon.

-Gejr :)

gejr 03-20-2007 06:31 AM

Ok, I managed to install it with Anaconda. The installer looked really buggy and colors were flying everywhere, but at least it's installed now and works well.

My only problem now is to install the nvidia drivers. How would I do this in Sabayon? There's no envy available and I tried the driver from the nvidia site but it complained about me not having the kernel sources which gives me another problem, cause i don't know how/where to get them.

Doh..I feel a bit lost here, but it's only this nvidia thing stopping me from fully enjoying this.

Brian1 03-20-2007 04:54 PM

Never heard of Sabayon but check out the site and looks nice. I used their search tool for nvida and there was help for that there. Give that a try.


drewbug01 03-21-2007 09:38 AM

Sabayon's a great distro (although it never really agreed with my hardware). When I was attempting to run it, I also had installation errors, although it finally installed.
Sabyon is based on Gentoo Linux. Gentoo linux doesn't utilize a "normal" package manager like Ubuntu/Debian, or an RPM system. ( :-D I call debian a package manager because it works, unlike RPM... just in my experience) They use the portage system, which many people swear by. You access it with a command called "emerge". If memory serves me correctly, Sabayon ships a front-end to emerge called Kuroo. That should help you to install your kernel sources. Aside from that, I can't help you with nvidia drivers, I'm stuck (for now) with ATI! :-)
Some useful links
Sabayon Wiki
Gentoo Wiki
Main gentoo site. Tons of documentation.

Is everything else running?
Best of Luck,

All times are GMT -5. The time now is 10:51 PM.