-   Linux - Distributions (
-   -   Need a distro that has SATA down pat (

corbintechboy 06-24-2005 09:17 PM

Need a distro that has SATA down pat
I have a new gateway 507GR. I have tried to install about 4 distros today and the install will go fine up to the point of installing grub to the mbr. I have a 3 gig pent4 h/t, 200 gig sata150 hard drive. Video and sound I will tackle when I find one that can do my sata setup.

Thanks in advance for any help.

salparadise 06-25-2005 01:22 AM

The only distro's I've used on SATA drives are Mandrake and Ubuntu. Of the two, Ubuntu worked perfectly.

Bruce Hill 06-25-2005 01:30 AM

I have Slackware running on two computers with SATA drives.
I use LiLO and not GrUB, but Slackware-10.1 has no problems
with the drives. Just enter sata.i at the boot: prompt and you
will be all set.

Check Jeff Garzik's pages for the status of your SATA controller.

69_rs_ss 06-25-2005 10:41 AM

I've had Suse 9.1, 9.2, 9.3 and Gentoo running great on Sata. What chipset does your board use?

corbintechboy 06-25-2005 11:37 AM

perating System System Model
Windows XP Home Edition Service Pack 2 (build 2600) Gateway 2000 507GR
System Serial Number: CA
Processor a Main Circuit Board b
3.00 gigahertz Intel Pentium 4
16 kilobyte primary memory cache
1024 kilobyte secondary memory cache Board: Intel Corporation D915GAG AAC77881-305
Serial Number: FCAG51000069
Bus Clock: 200 megahertz
BIOS: Intel Corp. AG91510J.15A.0816.2005.0214.1818 02/14/2005
Drives Memory Modules c,d
200.04 Gigabytes Usable Hard Drive Capacity
190.70 Gigabytes Hard Drive Free Space

_NEC DVD_RW ND-3520A [CD-ROM drive]

Generic USB CF Reader USB Device [Hard drive] -- drive 2
Generic USB MS Reader USB Device [Hard drive] -- drive 4
Generic USB SD Reader USB Device [Hard drive] -- drive 1
Generic USB SM Reader USB Device [Hard drive] -- drive 3
WDC WD2000JD-22HBB0 [Hard drive] (200.05 GB) -- drive 0 502 Megabytes Installed Memory

Slot 'J6H1' has 256 MB (serial number 0xFFFF7112)
Slot 'J6H2' is Empty
Slot 'J6J1' has 256 MB (serial number 0xFFFF5099)
Slot 'J6J2' is Empty
Local Drive Volumes

c: (NTFS on drive 0) 195.49 GB 188.88 GB free
d: (FAT32 on drive 0) 4.55 GB 1.81 GB free
Network Drives
None detected
Users (mouse over user name for details) Printers
local user accounts last logon
Owner 6/25/2005 10:54:04 AM (admin)
local system accounts
Administrator never (admin)
ASPNET never
Guest never
HelpAssistant never
SUPPORT_388945a0 never

DISABLED Marks a disabled account; LOCKED OUT Marks a locked account

Lexmark 510 Series on USB001
Controllers Display
Intel(R) 82801FB Ultra ATA Storage Controllers - 2651
Intel(R) 82801FB/FBM Ultra ATA Storage Controllers - 266F
Primary IDE Channel [Controller] (2x)
Secondary IDE Channel [Controller] Intel(R) 82915G/GV/910GL Express Chipset Family [Display adapter]
Proview 17.7 [Monitor] (17.7"vis, s/n FEVL54291571U, April 2005)
Bus Adapters Multimedia
Intel(R) 82801FB/FBM USB Universal Host Controller - 2658
Intel(R) 82801FB/FBM USB Universal Host Controller - 2659
Intel(R) 82801FB/FBM USB Universal Host Controller - 265A
Intel(R) 82801FB/FBM USB Universal Host Controller - 265B
Intel(R) 82801FB/FBM USB2 Enhanced Host Controller - 265C Realtek High Definition Audio
Communications Other Devices
SoftV92 Data Fax Modem with SmartCP

1394 Net Adapter
Intel(R) PRO/100 VE Network Connection
primary Auto IP Address:

OHCI Compliant IEEE 1394 Host Controller
Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
Microsoft PS/2 Mouse
USB Mass Storage Device
USB Printing Support
USB Root Hub (5x)

This is the output from belarc.

corbintechboy 06-25-2005 06:34 PM

Does this mean all is hopeless? I dont know why but belarc misread my bus speed it is in fact 800mhz (I did another test to make sure).
If I can't get linux to run I dont know what I will do.

Thanks for any help.

Bruce Hill 06-25-2005 07:14 PM

Pardon me while I laugh out loud, mate, but I think it's funny that anti_microsoft
used a Windoze app to post the output of his box for a Linux forum. All you really
needed was Intel® 915G Chipset. Please forgive me...

Forget that BelArc Advisor posted some data're going to use *nix. :)

Did you check this out? First hit on Google. Intel® Quick Start Kit for Linux*
I wonder what that does...

Second hit on Google...
Just ignore that guys monitor hub problem, and Fedora junk, and look at
some stuff that's common, such as it using e100: eth0: Intel(R) PRO/100
Network Connection for the NIC; and he's running kernel 2.4.29 which is
the one in Slack-10.1; his USB 2.0 root hub is recognized; onboard PCI
Express graphics works; etc. Sound should be no problem, because I
believe all onboard Intel chips use the same modules.

Anyway, this is the Intel page for your 915G chipset information.

Great news! You have the best SATA controller going for Linux today,
the AHCI controller which works with Native Command Queuing (NCQ).
Look at Jeff Garzik's pages where I referred you earlier.

Mate, you should just boot with Slackware CD1 and select that sata.i
kernel. Go for it!

Matir 06-25-2005 07:38 PM

Gentoo works for my SATA system.

All times are GMT -5. The time now is 03:40 PM.