-   Linux - Distributions (
-   -   MySQL not functioning (

vadivelsurya 02-08-2007 03:16 AM

MySQL not functioning
I,ve installed Ubuntu6.0 and Fedora in two IBM desktops,Slackware 11.0 in assembled Intel(915 chipset) desktop and Open SuSe 10.2 in a Laptop HP Presario 2500.
Xampp was installed in all the above distributions.MySQL is not functioning in Slackware,open Suse and Fedora, but works ok in Ubuntu, when directly logged in as root user. The error is "Error 2002 (HY000) Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)".
Will somebody please help.

wpn146 02-08-2007 11:22 AM

You might want to check:

cgjones 02-08-2007 11:24 AM

I ran into a similar problem on Slackware once. Make sure that MySQL is running, and if it is, have you initialized the base tables that MySQL needs? The following command should set up these tables.


vadivelsurya 02-14-2007 04:28 AM

mysql solved
Thanks a lot for all who guided. mycnf was edited for the data path (for sock etc)and SQL is working fine.Once again thanks for all.

All times are GMT -5. The time now is 12:25 AM.