-   Linux - Distributions (
-   -   mute audio CD on SuSE 9.1 (

Joseph Schiller 09-01-2004 11:26 PM

mute audio CD on SuSE 9.1

I considered posting with some trepidation, there seem to be a plethora of SuSE 9.1 issues with audio CD sound and 2.6 kernel ... but I'm in the same boat with a new twist.

1. Upgraded 267 MHz MMX desktop from SuSE 8.2 to 9.1 and seems to work AOK with some minor annoyances. Audio CD sound works fine after running YAST in auto configure mode, it's using ymfpci driver.

2. Installed SuSE 9.1 from same install disks on brand spankin' new Toshiba Satelite A55S326 Centrino 1.6 GHz 512 RAM 60 GB drive mulit CD-RW/DVD notebook, after shrink wrapping WinXP NTFS partition. Everything went well. Can't get audio CD sound, but do have sound running Chromium or Frozen Bubble, or even under WinXP. It seems a software issue/bug.

lspci returns
0000:00:1f.5 Multimedia audio Controller Intel Corp. 82801DB AC'97 Audio Controller (rev 03)
0000:00:1f.6 Modem: Intel Corp 82801 DB AC'97 Modem Controller (rev 03)

duno, shared IRQ for both? investigated that in vain

/proc/asound/cards returns
0 [I82801DBICH4]: ICH - Intel 82801DB-ICH4
Intel 82801DB-ICH4 at 0x1f080800, irq 11

/proc/interrupts returns
10: 0 XT-PIC uhci_hcd
11: 10469 XT-PIC uhci_hcd, ehci_hcd, ohci_1394, yenta, eth0, Intel 82801DB-ICH4, Intel 82801DB-ICH4 Modem

It seems IRQ 11 is the kitchen sink though.

verified /etc/hotplug/blacklist contains the line snd-intel8x0m as well as snd_intel8x0m

did /etc/init.d/alsasound restart under root w/o any error messages

running alsaconf and alsamixer, I hear the sample loud and clear

BUT no audio CD sound in KsCD or XMMS. The closest I came was after typing URL audiocd:/ in the konqueror right clicked on any track06.cda and opened with kaboodle. I did hear music, but every other second it would read from the disk and produce annoying stop-and-go sound, not CD quality by any means. The CD is good, tried other CDs also.

The kernel version is 2.6.4-52-default. I've tried the obvious and obviously failed.


Joesph Schiller

J.W. 09-02-2004 02:58 AM

When you run alsamixer, the CD volume control is to the far right, and may not appear initially. You need to use the right arrow key to move all the way through the set of volume controls. Did you do that, and verify that the volume level for the CD is sufficiently high?

Also, both KsCD and XMMS have their own separate volume controls, which may be set to zero. They are in the form of a slider bar, make sure that they are turned up as well. Good luck with it -- J.W.

Joseph Schiller 09-02-2004 06:35 AM

Affirmative, running alsamixer the CD volume is turned up 100%, I scrolled through all the settings and tried them all. Initially I thought it's got something to do with 'reading' the device files on audio CD, because in XMMS I don't seem able to get track info, or else with the IRQ 11. On the desktop the Yamaha card is on IRQ 10 and does not share that with other devices. What's strange is that sound files in games work fine.

Joeseph Schiller

motub 09-03-2004 04:29 PM

In XMMS, right-click any part of the window, and go to Options=>Preferences. Select the CD Audio player plugin and click the "Configure" button.

1. Check that the devices are correct; especially the directory that is the normal mount point for your CD-ROM drive.

2. Change the "Play mode" from Analog to Digital extraction. Analog will only work if you have a physical cable connecting your sound card to your CD-ROM drive, which you probably don't have in a laptop.

3. Go to the CD info tab and enable CDDB .

4. Hit "OK" in this sub-window and then "Apply" in the main window.

Hope this helps.

Joseph Schiller 09-07-2004 03:22 PM

Thanks for the advice. I did find that XMMS is config'd for device: /dev/cdrom and directory: /mnt/cdrom, I did change the radio button to 'digital audio extraction'. I also noticed that the output is set for 'automatic detection' using '' plugin and config'd for buffering 400 ms (the available range is 200-1000 ms). But when I try to launch XMMS to play, I get a pop-up that allows me to select directories and different devices, but I'm not able to find anything for /dev/cdrom or /mnt/cdrom. There's only /media/dvdram. I think this is the crux of the problem, the the app is not able to "read" audio .cda files or .wav files. I'm posting, therefore, the relavant /etc/fstab and /etc/mtab. Some of these 'cryptic' device specs are innovation of the 2.6 kernel, I think. BTW, also expanded permissions /dev/cdrom->/dev/hdc which first had all permissions, the device pointed to did not.

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid-users,umask=0002,nls=utf8 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvdram /media/dvdram subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

/dev/hda3 / reiserfs rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/hda1 /windows/C ntfs (cont'd below)ro,noexec,nosuid,nodev,gid=111,umask=0002,nls=utf8 0 0
/dev/hdc /media/dvdram subfs ro,nosuid,nodev,fs=cdfss,procuid,iocharset=utf8 0 0
usbfs /proc/bus/usb usbfs rw 0 0

I think the problem must be with the following 'daisy-chain' /dev/cdrom->/dev/hdc->/dev/dvdram. The multi-function drive needs something here to make it read audio files, so I think, otherwise, the only other thing left is the IRQ 11.


Joseph Schiller

motub 09-07-2004 04:40 PM

If you don't have a /dev/cdrom or a /mnt/cdrom, but instead /dev/dvdram and /media/dvdram, you should change the devices in XMMS to what the devices really are.

The program is not psychic-- it's just guessing at the defaults. It's up to you to tell it the real lay of the land, which is what's in /etc/fstab.

Joseph Schiller 09-07-2004 09:45 PM

Negatory. Changing from /mnt/cdrom to /dev/dvdram and from /mnt/cdrom to /media/dvdram has had no effect even though when I click 'check drive' pushbutton, device check is ok and there are 12 tracks on the /media/dvdram and total playing time is OK also. Cannot play audio CD nonetheless. There's something broken in the new kernel, but it does not manifest itself in consistent fashion. It seems to work under some circumstances but not others. I wonder if there's a bug in the auto-mounter or with the subfs, but don't really understand the "new approach." Audio CD was solved long ago, why would we go back to the stone age to make tools?

Joseph Schiller

All times are GMT -5. The time now is 05:44 AM.