-   Linux - Distributions (
-   -   Mint 6 install fails to boot dev/sda1/ does not exist (

JimboJuggs 03-02-2009 04:18 PM

Mint 6 install fails to boot dev/sda1/ does not exist
Evening, here's a head scratcher;
I had a dual boot old pc, 1ghz AMD, 512mb RAM, 2 IDE drives (40gig (XP) & 10gig (Mandrake 10.1))

Downloaded Mint v6, check sum ok, burned iso slowly.
CD fails to boot normally. compatibility mode works though.
Decided to wipe off XP. So selected Mint to install; partitioning set to 'guided: entire disc (40gig (XP))'.

After completion grub loaded, then mint splash screen, then;
ALERT! /dev/sda1 does not exist. Dropping to a shell!

Re-installed, same result. Mandrake booted from grub. Mem test boots, but no mint. Formatted Mandrake in case it was clashing but no, Mint still not booting.

Checked Mints forum (tried registering), tried installing after partitioning manually, same result. Tried changing grubs menu.lst to use the UUID. Tried changing etc/fstab to show dev/sda1 instead of UUID and still no joy.

Tried booting with supergrub live cd. Not entierly sure what Im doing with it but every option fails. If I load Mint as a LiveCD I can see all the files on the HD.

Sounds as though it should be a simple fix but Im lost.
Any ideas? Im a bit of a newb, but am a quick learner so please be patient.

Below is the the only thing I can find different. The answer is usually (hd0,1) according to some posts but Im out of my depth now.

Grub> find /boot/stage1

Any help much appreciated,

camorri 03-03-2009 12:54 PM


Below is the the only thing I can find different. The answer is usually (hd0,1) according to some posts but Im out of my depth now.

Grub> find /boot/stage1
If Mint is on the first partition, then it will be (hd0,0). In grub, zero is one. So hd0 is the first hard disk, and the second zero is the first partition.

I have only one system installed, here is one entry from a working grub.


title desktop
kernel (hd0,0)/boot/vmlinuz- BOOT_IMAGE=desktop_2.6.27.14- 1mnb root=UUID=88b23ea4-9643-4f50-b75d-ba90e254b259 resume=UUID=88f8a2b1-981c-42 d7-9657-58ab56299fa1 splash=silent vga=791
initrd (hd0,0)/boot/initrd-
Have a look at the UUID, if that is messed up it won't boot. Your UUID will be different than mine...

JimboJuggs 03-04-2009 05:13 PM

Hello Cliff,
Thanks for taking me on ;)

Been digging around some forums and...
My disks UUID
mint@mint ~ $ sudo vol_id -u /dev/sda1
Also matches fstad
# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=b8935cba-80ac-45f7-bdeb-48dbc77bda0e / ext3 relatime,errors=remount-ro 0 1
# /dev/sdb1
UUID=49A6-DF32 /backup vfat utf8,umask=007,gid=46 0 1
# /dev/sda3
UUID=f41b2d6b-5330-4b95-b5a2-3da81a20eb87 /home ext3 relatime 0 2
# /dev/sda5
UUID=26851ac7-9df3-4667-b7d1-9f2bcdbfabcd none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

Further, grubs menu.lst
title Linux Mint 6, kernel 2.6.27-7-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.27-7-generic root=/dev/sda1 ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic

still can't see anything wrong.
Any thoughts?

sycamorex 03-04-2009 05:38 PM

Try to change your menu.lst

root=/dev/sda1 ro quiet splash

root=UUID=youruuidid ro quiet splash

camorri 03-04-2009 06:34 PM

I would like you to try what sycamorex has suggested. That is the only thing that seems to be different than my working grub file.

Here is the first entry on mine.


title linux
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=88b23ea4-9643-4f50-b75d-ba90e254b259 resume=UUID=88f8a2b1-981c-42d7-9657-58ab56299fa1 splash=silent vga=791
initrd (hd0,0)/boot/initrd.img
Of course the vol_id's are different.

JimboJuggs 03-05-2009 09:03 AM

Sycamorex, Cliff,


I've tried changing the menu.lst file to;
- root=UUID=b8935cba-80ac-45f7-bdeb-48dbc-77bda0e

Boot failed at same point but with a slightly different error;
- ALERT! /dev/disk/by-uuid/b8935cba-80ac-45f7-bdeb-48dbc-77bda0e does not exist.

I was reading another post 'Linux won't boot' on Linux Mint Forums and found this line;
- change grub entry to replace "quite splash" with noapic noacpi nosplash"

Well that sort of did it. I do not know what these terms are but guessing hardware set ups.
So, now I reach the login screen, hooray, but after about 1 min or so the system hangs, initially I had just enough to to set first boot preferences. No mouse movement, keyboard CAPS/Num lock lights flashing.

This was happening from time to time with the livecd but thought once installed it would be stable. So putting 2 and 2 together I reckon its a hardware issue.
Any thoughts on a work around? Can I update via liveCD?


camorri 03-05-2009 09:23 AM

ACPI deals with power, fan control etc. Here is a link that may help you at least understand..

and a link that defines the difference between acpi and apic.

I know you posted this at the top of the thread,


I had a dual boot old pc, 1ghz AMD, 512mb RAM, 2 IDE drives (40gig (XP) & 10gig (Mandrake 10.1))
What make and model of system are we dealing with? There may be some information we can find, if I knew which one...

sycamorex 03-05-2009 01:53 PM

I used to have problems like that with my laptop - you could also try passing the following
parameters to the kernel: nolapic, acpi=off (try some combinations of them and the ones you already mentioned)

JimboJuggs 03-05-2009 05:37 PM

This PC is made by Time (was owned by Tiny before they went bust).
Probably manufactured about 2001, was originaly shipped with XP.
1GHz AMD Athlon chip
512mb ram
Not sure of the motherboard make, BIOS is origanal.
40gb HDD
CD writer/DVD reader
Most of their parts are non-descript generic type components.
I've looked on the web for any info on Time Computers, but they've sunk without trace.

Had a look through my BIOS set up and disabled ACPI.
- Not sure if this is a good thing or not.
System booted up I got logged in. Thinking I'd cracked it, it froze again after about 20mins.
Rebooted, got logged in again, left it for a while (dinner time), when I came back it was still running! Update manager showed 243 updates. That does introduce a few more variables but hoping there is a fix in there somewhere.

Could it be that apic is an Intel technology which might be clashing with an AMD set up?
I'll try the: nolapic acpi=off arguments as well.

Thanks for sticking with me...

camorri 03-06-2009 08:57 AM

You are welcome. I was going to suggest you look for any BIOS updates, but considering the company is bust, you are probably out of luck, unless the BIOS was supplied by a well know BIOS company.

Good luck with it...

All times are GMT -5. The time now is 10:17 PM.