LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   linux-image-generic-hwe-18.04 and linux-generic-hwe-18.04 upgrade failure on Linux Mint 19.3 (https://www.linuxquestions.org/questions/linux-distributions-5/linux-image-generic-hwe-18-04-and-linux-generic-hwe-18-04-upgrade-failure-on-linux-mint-19-3-a-4175673007/)

rjo98 04-11-2020 07:13 AM

linux-image-generic-hwe-18.04 and linux-generic-hwe-18.04 upgrade failure on Linux Mint 19.3
 
Anyone know the proper way to fix this? My limited how to fix failed update knowledge typically leads to a wipe and reload, which I'm trying to avoid this time :doh: Only thing i've tried so far was a sudo apt-get update -f which didn't seem to help, as well as a clean then update.

Code:

(Reading database ... 317754 files and directories currently installed.)
Preparing to unpack .../linux-modules-extra-5.3.0-46-generic_5.3.0-46.38~18.04.1_amd64.deb ...
Unpacking linux-modules-extra-5.3.0-46-generic (5.3.0-46.38~18.04.1) over (5.3.0-46.38~18.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/linux-modules-extra-5.3.0-46-generic_5.3.0-46.38~18.04.1_amd64.deb (--unpack):
 unable to open '/lib/modules/5.3.0-46-generic/kernel/fs/nls/nls_cp1250.ko.dpkg-new': Operation not permitted
Errors were encountered while processing:
 /var/cache/apt/archives/linux-modules-extra-5.3.0-46-generic_5.3.0-46.38~18.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up linux-modules-5.3.0-46-generic (5.3.0-46.38~18.04.1) ...
Setting up linux-headers-5.3.0-46 (5.3.0-46.38~18.04.1) ...
Setting up linux-image-5.3.0-46-generic (5.3.0-46.38~18.04.1) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-5.3.0-45-generic
I: /initrd.img.old is now a symlink to boot/initrd.img-5.3.0-45-generic
I: /vmlinuz is now a symlink to boot/vmlinuz-5.3.0-46-generic
I: /initrd.img is now a symlink to boot/initrd.img-5.3.0-46-generic
dpkg: dependency problems prevent configuration of linux-image-generic-hwe-18.04:
 linux-image-generic-hwe-18.04 depends on linux-modules-extra-5.3.0-46-generic; however:
  Package linux-modules-extra-5.3.0-46-generic is not installed.

dpkg: error processing package linux-image-generic-hwe-18.04 (--configure):
 dependency problems - leaving unconfigured
Setting up linux-headers-5.3.0-46-generic (5.3.0-46.38~18.04.1) ...
/etc/kernel/header_postinst.d/dkms:
 * dkms: running auto installation service for kernel 5.3.0-46-generic

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j4 KERNELRELEASE=5.3.0-46-generic -C /lib/modules/5.3.0-46-generic/build M=/var/lib/dkms/virtualbox/5.2.34/build........
cleaning build area...

DKMS: build completed.

vboxdrv.ko:
Running module version sanity check.
 - Original module
  - No original module exists within this kernel
 - Installation
  - Installing to /lib/modules/5.3.0-46-generic/updates/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
  - No original module exists within this kernel
 - Installation
  - Installing to /lib/modules/5.3.0-46-generic/updates/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
  - No original module exists within this kernel
 - Installation
  - Installing to /lib/modules/5.3.0-46-generic/updates/

vboxpci.ko:
Running module version sanity check.
 - Original module
  - No original module exists within this kernel
 - Installation
  - Installing to /lib/modules/5.3.0-46-generic/updates/

depmod...

DKMS: install completed.
  ...done.
Setting up linux-headers-generic-hwe-18.04 (5.3.0.46.102) ...
dpkg: dependency problems prevent configuration of linux-generic-hwe-18.04:
 linux-generic-hwe-18.04 depends on linux-image-generic-hwe-18.04 (= 5.3.0.46.102); however:
  Package linux-image-generic-hwe-18.04 is not configured yet.

dpkg: error processing package linux-generic-hwe-18.04 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for linux-image-5.3.0-46-generic (5.3.0-46.38~18.04.1) ...
/etc/kernel/postinst.d/dkms:
 * dkms: running auto installation service for kernel 5.3.0-46-generic
  ...done.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.3.0-46-generic
cryptsetup: WARNING: Invalid source device /swapfile
cryptsetup: WARNING: target cryptswap1 has a random key, skipped
/etc/kernel/postinst.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Sourcing file `/etc/default/grub.d/60_mint-theme.cfg'
Generating grub configuration file ...
Found theme: /boot/grub/themes/linuxmint/theme.txt
Found linux image: /boot/vmlinuz-5.3.0-46-generic
Found initrd image: /boot/initrd.img-5.3.0-46-generic
Found linux image: /boot/vmlinuz-5.3.0-45-generic
Found initrd image: /boot/initrd.img-5.3.0-45-generic
Found linux image: /boot/vmlinuz-5.0.0-32-generic
Found initrd image: /boot/initrd.img-5.0.0-32-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
File descriptor 9 (pipe:[44809]) leaked on lvs invocation. Parent PID 17293: /bin/sh
File descriptor 10 (pipe:[44809]) leaked on lvs invocation. Parent PID 17293: /bin/sh
File descriptor 11 (pipe:[46825]) leaked on lvs invocation. Parent PID 17293: /bin/sh
File descriptor 67 (/root/.synaptic/selections.proceed) leaked on lvs invocation. Parent PID 17293: /bin/sh
done
Errors were encountered while processing:
 linux-image-generic-hwe-18.04
 linux-generic-hwe-18.04


sp331yi 04-11-2020 09:17 AM

Maybe see this foreign post for a hint? Personally, I dont deal with 'buntus much anymore. Hope it helps!

rjo98 04-11-2020 09:50 AM

Thanks, I will check it out. I'm about done with LM after this issue, for it being designed to be average user friendly it sure messes up a lot to where the average person would be screwed.

rjo98 04-11-2020 10:51 AM

So ran a apt policy linux-generic* and it shows this

Quote:

apt policy linux-generic*
linux-generic-hwe-16.04-edge:
Installed: (none)
Candidate: 4.15.0.96.87
Version table:
4.15.0.96.87 500
500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
4.15.0.20.23 500
500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
linux-generic-hwe-16.04:
Installed: (none)
Candidate: 4.15.0.96.87
Version table:
4.15.0.96.87 500
500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
4.15.0.20.23 500
500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
linux-generic-hwe-18.04-edge:
Installed: (none)
Candidate: 5.3.0.46.102
Version table:
5.3.0.46.102 500
500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
linux-generic-hwe-18.04:
Installed: 5.3.0.46.102
Candidate: 5.3.0.46.102
Version table:
*** 5.3.0.46.102 500
500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
100 /var/lib/dpkg/status
linux-generic:
Installed: (none)
Candidate: 4.15.0.96.87
Version table:
4.15.0.96.87 500
500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
4.15.0.20.23 500
500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

sp331yi 04-12-2020 10:05 AM

OP -- yes, I tried LMDE 4 32bit and found it buggy, the forum unfriendly, the Devs unresponsive. Will not go there, again, for their ubuntu-based distro. From what I read in other 'buntu fora, it's rather buggy of late. GIGO!

rjo98 04-12-2020 10:07 AM

Think I'm just going to wipe and reload and try a new OS. Thanks for the help.

uteck 04-12-2020 10:15 AM

The error is for this file
Code:

/lib/modules/5.3.0-46-generic/kernel/fs/nls/nls_cp1250.ko.dpkg-new
Look the permissions for it to see if there is something goofy, then try deleting it and the install file in
Code:

/var/cache/apt/archives/linux-modules-extra-5.3.0-46-generic_5.3.0-46.38~18.04.1_amd64.deb
. Run the update again. If the problem persists, then it would seem the new package has an error.


All times are GMT -5. The time now is 05:33 AM.