LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 07-05-2005, 06:27 PM   #1
valnar
Member
 
Registered: May 2005
Posts: 66

Rep: Reputation: 15
Linux distro for ATI 9600?


I'm looking for a desktop distro that has support for the genuine ATI Radeon 9600 driver out of the box, or at least something with detailed instructions on how to get it to work.

Debian based system preferred, but will accept RPM if I have to. I've been unsuccessful finding something to work on this PC, and I only need it to run the ATI (fglrx) driver appropriately so my kid can play games.

I'm not experienced with kernel building, hence my difficulty in getting any kernel based driver to run. But I can always follow directions....


Robert
 
Old 07-05-2005, 06:57 PM   #2
AndyMCR
Member
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Slackware Current
Posts: 39

Rep: Reputation: 15
Hi,

Have you tried the new ATI installer? Its a ./ .run file, should work straight off for most newish cards... Did for me anyway, just remember to run fglrxconfig with your details (pretty straightforward, just get your monitor setting right) and enable POSIX memory (post here if you need help)

Post for more help,

Andy
 
Old 07-06-2005, 03:22 AM   #3
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
it works in every distro i try really , so try the new installer and post back if u have any problems
 
Old 07-06-2005, 05:09 AM   #4
valnar
Member
 
Registered: May 2005
Posts: 66

Original Poster
Rep: Reputation: 15
I tried it once on Libranet, but it didn't work too well. My guess is the distros which have their own custom front end apps which manage the xorg.conf file don't like being messed with. Can any of you name some exact distros you tried it on and it works?

Robert
 
Old 07-06-2005, 05:21 AM   #5
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
it worked with me in libranet , you just have to choose these options

Do you want to initialize xfree86-dga (y/n)? [n] y

Do you want to export pseudo color visuals (y/n)? [n] n

Do you want to synchronize buffer swaps
with the vertical sync signal (y/n)? [n] y

Do you want to use the external AGP GART module (y/n)? [n] y

in fglrxconfig

it worked with me in mandrake , libranet , kanotix (easiest as it has a script that will download the driver and install it for you) , debian , ubuntu , slackware
 
Old 07-06-2005, 07:45 AM   #6
valnar
Member
 
Registered: May 2005
Posts: 66

Original Poster
Rep: Reputation: 15
I'll those options a try. Thanks!

Robert
 
Old 07-31-2005, 04:48 AM   #7
t_4halo
LQ Newbie
 
Registered: Jul 2005
Distribution: mepis, slackware,
Posts: 2

Rep: Reputation: 0
Tried Kanotix, Mepis, and Slackware, all were HDD installs With the ATI Proprietary Driver. Each time I was unable to get 3D acceleration to full functionality. I followed the instructions each time according to the post from heema. Quote "it worked with me in libranet , you just have to choose these options

Do you want to initialize xfree86-dga (y/n)? [n] y

Do you want to export pseudo color visuals (y/n)? [n] n

Do you want to synchronize buffer swaps
with the vertical sync signal (y/n)? [n] y

Do you want to use the external AGP GART module (y/n)? [n] y

in fglrxconfig

it worked with me in mandrake , libranet , kanotix (easiest as it has a script that will download the driver and install it for you) , debian , ubuntu , slackware"

My Hardware:

Tyan Trinity S2380 Motherboard
512 MB of SDRAM
AMD Athlon 750 Mhz Slot A
ESS Technology ES1969 Solo-1 Audiodrive sound chip
D-Link RTL8139 NIC
Teac CD-W58E 8x8x32 CDRW
ATI Radeon 9600 Pro
WDC WD400BB 40 GB HDD

Any other tips would be appreciated.

I just now found this, possibly overlooked when searching google -
http://www.rage3d.com/content/articles/atilinuxhowto/

I will post back if this works... or not.


Last edited by t_4halo; 07-31-2005 at 05:01 AM.
 
Old 07-31-2005, 05:00 AM   #8
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
in kanotix all you have to do is type as root :

update-scripts-kanotix.sh
install-kernel-source-vanilla.sh
install-radeon-debian.sh

thats it
 
Old 07-31-2005, 05:02 AM   #9
t_4halo
LQ Newbie
 
Registered: Jul 2005
Distribution: mepis, slackware,
Posts: 2

Rep: Reputation: 0
OK, I will will try that first.

1. Followed instructions for kanotix. Launched glxinfo

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None

Launched glxgears, and screen goes black, computer frozen solid (ctrl+alt+f1, alt+SysRq+b, etc.). Had to use reset button. Searched google for fglrxconfig.

2. Followed instructions per http://www2.ati.com/drivers/linux/linux_3.12.0.html per section Workaround editing XF86Config-4, since this seemed relevant to my experience per glxgears.

3. Switched Option "MonitorLayout" "AUTO, AUTO" in /etc/X11/XF89Config-4 to Option "MonitorLayout" "CRT, CRT"
No go. Right now, the pc is in Console mode on tty1. I got here because when the system was booting up, the screen went black, so I decided to try ctrl+alt+f1. I have a message that says Not starting X display manager (xdm); it is not the default display manager. Went back to http://www2.ati.com/drivers/linux/linux_3.12.0.html to have another look.

4. Still cannot find anything relevant. Searched some more on google for fglrxconfig. Haven't seen anything yet.

I am wondering if I should set xdm to default....

Last edited by t_4halo; 07-31-2005 at 08:56 AM.
 
Old 07-31-2005, 05:03 PM   #10
JediDB
Member
 
Registered: Jul 2005
Location: USA - IL
Distribution: Mepis
Posts: 131

Rep: Reputation: 16
Hmm, i hope you get your issue fixed. I use Mepis and my ATI AGP card is fully operational from the Install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ati Mobility radeon 9600 driver for Linux not found! alpha128 Linux - Laptop and Netbook 6 12-03-2004 12:58 AM
Can ATI mobility Radreon 9600 be configured on Linux? Kibosh Linux - Laptop and Netbook 16 09-02-2004 10:58 AM
My ATI 9600 Linux FIX!!!! maxsin Linux - Hardware 92 08-18-2004 08:42 PM
SuSE 9.1 - ATI Mobility 9600 (M10) - ATi Drivers 3.9.0 Beaviis Linux - Hardware 3 06-04-2004 12:51 PM
Problems with ATI 9600 Pro and Suse Linux 9.1 lord-darkness Linux - Hardware 9 05-06-2004 02:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 03:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration