LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 09-15-2009, 01:32 AM   #1
levian4
Member
 
Registered: Aug 2009
Posts: 68

Rep: Reputation: 15
kubuntu: chinese input?


hi,

how do i enable chinese (pinyin) input in kubuntu 9.04? i installed chinese through Regional & Language, n had the China flag shown on the panel, but switching among the US flag n China flag does nothing. i can only input alphabets all the same. did i miss out something?
 
Old 09-15-2009, 01:40 AM   #2
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
what about changing your language at your login screen??
 
Old 09-15-2009, 01:42 AM   #3
levian4
Member
 
Registered: Aug 2009
Posts: 68

Original Poster
Rep: Reputation: 15
mobinskariya,

will that change the language of the whole system? n how do i change the language at my login screen? sorry, i have limited linux knowledge.

Last edited by levian4; 09-15-2009 at 01:50 AM.
 
Old 09-15-2009, 02:00 AM   #4
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
at left bottom corner of login window there is option.. you can change language there(i havnt tried changing my language).
 
Old 09-15-2009, 02:14 AM   #5
levian4
Member
 
Registered: Aug 2009
Posts: 68

Original Poster
Rep: Reputation: 15
mobinskariya,

i logged out to look at the login window. besides "user" n "password" at the center of the page, in the bottom right corner, there are Session Type, Menu n today's Date. under Session Type, there are 3 choices - Default, KDE, Failsafe. under Menu, there are 5 choices - Switch User, Restart X Server, Remote Login, Console Login, Shutdown.
 
Old 09-15-2009, 02:19 AM   #6
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
oh no
im really sorry..iam using gnome as desktop environment and for me it is there.
 
Old 09-15-2009, 02:26 AM   #7
levian4
Member
 
Registered: Aug 2009
Posts: 68

Original Poster
Rep: Reputation: 15
mobinskariya,

it's fine, i welcome any idea i can try. hehe. trying to learn but i need help, knowing very little about linux.
 
Old 09-15-2009, 02:40 AM   #8
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
ok i have switched to slackware..now i am in kde.. did you change your language other than your country..i can change it and all my system changes to that language
 
Old 09-15-2009, 02:48 AM   #9
levian4
Member
 
Registered: Aug 2009
Posts: 68

Original Poster
Rep: Reputation: 15
mobinskariya,

where can i change my language? i am currently choosing USA as my language.
 
Old 09-15-2009, 02:51 AM   #10
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
under the country there is an option for add language.
 
Old 09-15-2009, 04:10 AM   #11
levian4
Member
 
Registered: Aug 2009
Posts: 68

Original Poster
Rep: Reputation: 15
mobinskariya,

under Regional & Language, i added "US English" n "Simplified Chinese" into the Languages box. it mentioned as a tooltip: "KDE programs will be displayed in the first available language in this list. If none of the languages is available, US English will be used." when i shifted "Simplified Chinese" to the top of the list n clicked on "Select System Language", the applications will be displayed in chinese, but i still didn't have the option to input in chinese. did i miss out anything?
 
Old 09-15-2009, 04:25 AM   #12
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
in regional and accessibility you have keyboard layout which is under country/region and language..in keyboard layout you have to select your layout variant..i can now type in my language in text editors
 
Old 09-15-2009, 04:34 AM   #13
levian4
Member
 
Registered: Aug 2009
Posts: 68

Original Poster
Rep: Reputation: 15
mobinskariya,

under Keyboard Layout, selecting China, the Layout Variant gave me 3 options: Default, Tibetan, Tibetan (with ASCII numerals). none of these are what i use to have chinese input, i need PinYin. did i miss out some installation steps? or do i have to download PinYin myself from somewhere else to have it work?
 
Old 09-15-2009, 04:55 AM   #14
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
may be you should install the require font and try again.
 
Old 09-15-2009, 05:07 AM   #15
everest40
Member
 
Registered: Jul 2008
Distribution: Ubuntu $LATESTVERSION
Posts: 168

Rep: Reputation: 67
Try this:
Open a terminal and type in the command "sudo apt-cache search pinyin"
that will provide a list of packages whose descriptions include the word pinyin; install some of them the same way you installed pidgin (sudo apt-get install packagename)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinese input djib Debian 20 06-16-2008 02:41 AM
Chinese input Sam Ng Linux - Software 1 05-04-2006 07:02 PM
Chinese input denning Slackware 16 02-24-2005 01:39 AM
Chinese input Cyberian Fedora 2 02-15-2005 07:32 AM
Chinese Input In Mdk 9.1 awtoc123 Linux - General 24 10-27-2003 07:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 07:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration