LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 05-31-2005, 12:43 PM   #1
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Rep: Reputation: 35
Knoppix hd install & X problems


Hi,

Yesterday I installed knoppix to a linux partition on the hard disk. It boots but there are several problems.

1.) On every boot it does slow hardware detection, it searches for pcmcia, usb deveices and many other and this is unneeded and slow. How can i prevent this? I read some of the startup scripts, but they seem too complicated and I'm afraid I'll mess the things up if I edit them.

2.) It knows it runs from hard disk but never automatically mount my Windows partition, I have to manually mount it (there is a proper entry in /etc/fstab). Where's the problem.

3.) Setting up the X server is mission impossible. Depending on my luck I either have the computer hanging, or the screen messed, or in the best case the X screen is Ok, but on the framebuffer console i can only see some dots and colorful lines. Using the VESA driver there aren't such problems, but it's slow and unreasonable cause there is an accelerated driver. The same happens also with the normal Debian - I never had success with Debian and X - it doesn't work properly no matter what I try.

I should ask why the poor Debian user have to stuck with the XFree86 when most of the popular distros are using X.org . And what's the magic with the Xfree86 in debian which prevents me from success? (When i first used Slackware, there were also problems with Xfree, but I was able to solve them).

I'm sorry for the long post, but it's really annoying to retry and retry with no success for relatively simple task.
 
Old 06-01-2005, 01:53 PM   #2
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
Anyone ? Please give me some advice. Somebody familiar with debian startup scripts ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Knoppix & Writing 1's & 0's to H/D xemous Linux - Newbie 4 01-26-2005 02:43 PM
Knoppix 3.6 - few problems after HDD install exo Linux - Newbie 4 11-22-2004 12:34 PM
Ardour problems on Knoppix 3.3 hd install acorn Linux - Newbie 3 06-29-2004 03:05 PM
xine1_rc2 & kxine source install problems in RH 9.0 & SB live found but no sound Dominik Linux - Software 2 12-02-2003 04:15 AM
Knoppix install problems pe2338 Debian 12 09-08-2003 08:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 03:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration