LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Kali Linux 2019.4 - 2020.1 (https://www.linuxquestions.org/questions/linux-distributions-5/kali-linux-2019-4-2020-1-a-4175670051/)

Kush7963 02-22-2020 02:22 AM

Kali Linux 2019.4 - 2020.1
 
Hello members please can someone help. I'll be straight forward I don't like the new distros kali linux has implemented in 2020.1 not the separation of live and installation ISOs but the default "non-root user" has created loads of issues for me personally so I cleaned up backed up anything worth saving and reverted back to 2019.4. I ran apt update && apt upgrade -y and from 2019.4 I've had a build upgrade to 2020.1.!!! I though if I didn't run the apt dist upgrade I would get away with it. I want to stay on 2019.4 but be able to update/upgrade the system. How can this be achieved?? Thanks. Kush

P.S I also still have the 2019.3 kali ISO build would that be an option to created usb persistence and update/upgrade from that or will I end up with 2020.1 again??....

pan64 02-22-2020 03:29 AM

I do not really understand your problem (actually I'm confused). What do you want to achieve, where did you stuck?

https://www.linuxquestions.org/quest...up-4175669710/

michaelk 02-22-2020 04:37 AM

Please read...
https://www.kali.org/news/kali-default-non-root-user/

Kush7963 02-22-2020 07:52 PM

First of all thank you for your replies.

Michaelk thank you very much for highlighting the Kali linux page containing "dpkg-reconfigure kali-grant-root" I've not tried this yet to hopefully get the expected outcome I have also only read as far as the paragraph containing that command so I'll finish reading the page as per the link in your reply and armed with this new and valuable information attempt too make various changes to create the kali os I want.


Pan64 your right you havnt understud my question and I apologise if I wasn't as clear and informative as I could have been. Especially after reading the post via the link you posted to me as that's definitely not anything to do with my problem.

As an example 1 particular problem i hit a brick wall with was using TOR Browser. Because it wont boot whilst logged into the root account as we all know when I was trying to use TOR as none-root user I got something like "access denied please enter root password" then trying $su and password the TOR Launcher would open box stating i cant use TOR whilst superuser!!! Catch 22 sinario basically unless setting TOR up using Alacarte forcing me to run it as root and only solving 1 problem with my os.

thank you. Kush


All times are GMT -5. The time now is 04:01 AM.