LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   jog dial (https://www.linuxquestions.org/questions/linux-distributions-5/jog-dial-33479/)

skoorbj 10-22-2002 07:54 PM

jog dial
 
ANyone know if you can configure Linux to use the jogdial as a 3rd mouse button - don't care about being able to scroll, just need that middle mouse button!!!

When I installed RH 8.0 and then 7.3 (see earlier post!!!) it seemed to think that I had a 3 button PS/2 mouse installed, so thought clicking the jogdail might have worked. Have tried the imps/2 protocol in XF86Config-4, to no avail.... :-(

Any clues??

Thanks.

vladkrack 10-24-2002 12:31 PM

Hi skoorbj,

You can try to put these lines in your XF86Config-4 file:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" " "IMPS/2"
Option "Emulate 3Buttons" "yes"
Option "ZAxisMapping" "4 5"

skoorbj 10-24-2002 01:15 PM

does this work for you???
 
I tried setting the mouse protocol to "imps/2" in
XF86Config-4 with no joy - if it worked surely I wouldn't
need to emulate 3 buttons???

Cheers,

Jon.

vladkrack 10-24-2002 02:18 PM

Yes it works for me :), as a button, and as a scroll;

try to set in mouseconfig tehe protocol Microsoft IntelliMouse (PS/2)

I read somewhere (can't remember now) that some mouse types don't work right with this module, but the problem was only the scroll.

see ya

skoorbj 10-25-2002 05:43 AM

weird!
 
Hi VladKrack

Here's the relevant sections of my XF86Config file (RH8 has dropped the -4)?? Unless I'm looking in the wrong place!

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

So first off I was really suprised to see 2 entries. If I change the protocol entry for Mouse0 to "IMPS/2" as you suggested and reboot then the mouse moves really erratically - jumping all over the place!!!

Any suggestions? Anyone?


Jon.

vladkrack 10-26-2002 12:15 PM

Hi,

At least for what I know, XF86Config was a configuration file for XFree86 v3, and XF86Config-4 are for XFree86-4.x.x., but if is it working for you, it's a wise option to keep it ...

About your two entries "Mouse0" and "Mouse1" they are usualy used to have 2 mouses at same screen, but, if you want to know what of then your system is using, look at the first section, it will be something like:

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Have you already tried # mouseconfig?

skoorbj 10-26-2002 12:38 PM

got it working....read on
 
Hi,

Thanks Vladkrack, though in the end the solution was not
editing XF86Config, but enabling a kernel module (sonypi) that
did the trick.

Running RH7.3 with kernel 2.4.18-3

First I put the following two lines into /etc/modules.conf

options sonypi minor=61
alias char-major-10-61 sonypi

rebooted

then running lsmod shows "sonypi" in the list of loaded modules

then you need to download sonypid from someplace on the net
(alcove?) I forget where - p.s. various people have hacked
sonypid to make the jogdial do what ever they want it to.

Compile sonypid and run it with sonypid & then you can use the
jogdial as a middle mouse button.

What a pain in the arse!!!!

Yours,

Jon.

beyond_2000 10-28-2002 09:03 AM

My computer is GR390, but the sound card doesn't work properly, when I play a song, the sound pause and again. How can I make it works well?

skoorbj 10-28-2002 10:45 AM

not sure this has anything to do with jogdial
 
Hi,

I have read that using ALSA is the way to get sound configured,
though I don't have any personal experience of this.

It seems like getting acpi to work may also be a prerequisite.

Yours,

Jon.

beyond_2000 10-28-2002 06:08 PM

ACPI does not work properly. When I try to configure it in system control center, it says ACPI maybe have start-up, but not work properly.
SuSE8.1 have installed ALSA and OSS together, should I must reinstall by myself?

aliensub 10-28-2002 09:17 PM

Quote:

Originally posted by vladkrack
Hi,

At least for what I know, XF86Config was a configuration file for XFree86 v3, and XF86Config-4 are for XFree86-4.x.x., but if is it working for you, it's a wise option to keep it ...

When x-server 4.x starts it first look for a XF86Config and if that doesnīt exist it looks for an XF86Config-4 (or the other way round, canīt remember....)

skoorbj 10-29-2002 07:03 AM

you're right
 
Jon

bence8810 06-30-2005 04:23 AM

Hi

I just found this thread, and I would like to achieve exactly the opposit that you guys achieved. I have a Vaio, and the 2.6.11 kernel. For me, I didnt need to set anything, just load the sonypi module, and scrolling and jogdial press works as a middle mouse button. Now, when I want to use some jogdial-app, like rsjog, or sjog, and when I press the jogdial, the menu pops up, and also it acts as a middle mouse button. So two things at the same time. I think that from 2.6.9 kernel, the middle mouse button and scroll is by default. So now, something is already listening to the jogdial, and when I load the optional application, rsjog, it will also listen to it. So when I press it, it will execute two things. Really annoying. Any ways to disable the default middle mouse clicking from the jogdial?

Thanks

Bence


All times are GMT -5. The time now is 09:53 AM.