-   Linux - Distributions (
-   -   Installing nvidia drivers on Suse 9.1? (

Flak Pyro 06-29-2004 11:29 PM

Installing nvidia drivers on Suse 9.1?
Ive tried using Yast but it gets to 50% and hangs, i have downloaded the ones of nvidias site but i dont really know how to install them, so far i have came up with this:

"push ctrl alt f1 and log in as root and then type in "#init 3" and press enter, check to make sure X isnt running on any other TTy's then cd to the dir that the driver is in, i will then "#sh driver name" after it works its magic i will type in "#sax2 -m 0=nvidia" and then "#init 5" and hope for the best. I will type those in with the # but not with the quotes. "

now i have no idea if that is right and the manual instructions at suses' siste
dont help at all, can someone please provide very clear and simple instructions on what to do here?

DavidPhillips 06-30-2004 02:42 AM

Open yast2

Select Software / Online Update

Next window..

Setup a server to download from.

Check Manually select patches.

Next window..

Inside YOU enable "Installable and Installed Patches" for "Show Patch
Category" and select "Download NVIDIA(r) Graphics Driver" from the
patches list (usually at the bottom of the list). Note, that you need
to mark it as "Update" (right mouse click) if you already installed it
before and the driver was uninstalled - for any reason. Proceed as
usual now. After YOU has finished restart your Xserver (i.e. logout
from your Xsession) and you're fine.

zoran 06-30-2004 03:11 AM

you should type as written in the manual.

you can also type at the boot time

init 3

to go directly to the console mode

than login as root

go to the directory where your driver is than

sh driver_name

sax2 -m 0=nvidia

you can also test the driver by typing


before you go to init 5

Neandartalietis 07-04-2004 08:38 AM

HElp me : not working : init 3 and "Ctrl+Alt+F1) --- i still in GUI ! ! !
log file :

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Jul 4 16:13:37 2004

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site :

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists... an X server appears to be running
ERROR: You appear to be running an X server; please exit X before installing.
For further details, please see the section INSTALLING THE NVIDIA DRIVER
in the README available on the Linux driver download page at
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at

DavidPhillips 07-04-2004 10:06 PM

You can't run the command line install script from X you need to go to runlevel three if your going to use that method of install.


open a root login on a terminal

init 3

BruceCadieux 07-05-2004 01:30 AM

You can install in the GUI.

Open a console, and cd to the directory where the driver is, and run the command below

sh --extract-only

That will extract all the files into a new directory, cd into that directory and run make install edit the XF86Config or Xorg file, or in the case of SuSE sax2, rerstart the xserver. Live happily ever after.

DavidPhillips 07-05-2004 05:34 AM

It might be best to exit out of X.

You may run into some rmmod problems if you don't. You would need to restart X anyway.

If you are upgrading the module you'll get this..

nvidia: Device or resource busy

Unable to remove existing NVIDIA kernel module.
Please be sure you have exited X before attempting
to install the NVIDIA kernel module.

*** Failed rmmod sanity check. Bailing out! ***

zappz 07-06-2004 08:05 PM

When I installed the nvidia drivers, I also thought the installer had 'hung'.
Nah...the installer downloads a 'downloader' to get the nvidia driver, the installer sits at 50% whilst it downloads the actual driver...which can take upto 30 minutes on a slow connection...
check your network may find its busy downloading the driver, but looks like its 'hung'.

atmckd 07-07-2004 07:27 PM

Nvidia 6106 and YaST Online Update
Hello people,
I tried using the online update to get and install the new drivers. However every mirror I look at has the same 5336 fetchnvidia script. Anybody know the address of a server that has updated that script to fetch the 6106 drivers and install them. I'm pretty new at this stuff and recomiling kernel modules is still a little above my head.

Thanks in advance!

All times are GMT -5. The time now is 05:56 AM.