LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 10-22-2019, 09:27 PM   #1
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Rep: Reputation: Disabled
Angry i am trying to run SPAN protocol ns2 in Cygwin in Windows 10. And i got error.


Code:
$ ns run-2Mb.tcl                                                                                                        ******: no errormodel specified.
couldn't read file "tcl/lib/ns-mobilenode.tcl": no such file or directory
    while executing
"source.orig tcl/lib/ns-mobilenode.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel source.orig[list $fileName]"
    invoked from within
"if [$instance_ is_http_url $fileName] {
set buffer [$instance_ read_url $fileName]
uplevel eval $buffer
} else {
uplevel source.orig[list $fileName]
..."
    (procedure "source" line 8)
    invoked from within
"source tcl/lib/ns-mobilenode.tcl"
    (file "run-2Mb.tcl" line 194)

pls reply.

Last edited by phyotay3; 10-23-2019 at 12:54 AM.
 
Old 10-22-2019, 11:01 PM   #2
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: A few
Posts: 3,983

Rep: Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113
Quote:
Originally Posted by phyotay3 View Post
couldn't read file "tcl/lib/ns-mobilenode.tcl": no such file or directory
This file is missing. I would google it.
Quote:
pls reply.
What is the question?

EDIT: Somebody had the same problem and solved it: https://www.linuxquestions.org/quest...errors-931774/

Last edited by berndbausch; 10-22-2019 at 11:05 PM.
 
Old 10-23-2019, 01:05 AM   #3
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by berndbausch View Post
This file is missing. I would google it.

What is the question?

EDIT: Somebody had the same problem and solved it: https://www.linuxquestions.org/quest...errors-931774/
USER@DESKTOP-ME30TBI /home/noureddine/ns-allinone-2.35-RC7/ns-2.35/tcl/ex
$ sh run-2Mb.tcl
run-2Mb.tcl: line 4: syntax error near unexpected token `('
run-2Mb.tcl: line 4: `set opt(chan) Channel/WirelessChannel'


USER@DESKTOP-ME30TBI /home/noureddine/ns-allinone-2.35-RC7/ns-2.35/tcl/lib
$ sh ns-mobilenode.tcl
ns-mobilenode.tcl: line 44: ARPTable: command not found
ns-mobilenode.tcl: line 45: next: command not found
ns-mobilenode.tcl: line 46: syntax error near unexpected token `}'
ns-mobilenode.tcl: line 46: `}'

i dont know what to do.i am so confused.Can u explain me?

Regards
phyotay3
Attached Files
File Type: txt ns-mobilenode.tcl.txt (22.3 KB, 2 views)
File Type: txt run-2Mb.tcl.txt (10.0 KB, 4 views)

Last edited by phyotay3; 10-23-2019 at 01:24 AM.
 
Old 10-23-2019, 01:26 AM   #4
ehartman
Senior Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 1,137

Rep: Reputation: 641Reputation: 641Reputation: 641Reputation: 641Reputation: 641Reputation: 641
Quote:
Originally Posted by phyotay3 View Post
$ sh run-2Mb.tcl
run-2Mb.tcl: line 4: syntax error near unexpected token `('
run-2Mb.tcl: line 4: `set opt(channel) Channel/WirelessChannel'

$ sh ns-mobilenode.tcl
You cannot run a tcl (Task Control Language) file through sh, you must install and use "tclsh" for those:
Quote:
Tcl, developed by Dr. John Ousterhout, is a simple to use text-based script language with many built-in features which make it especially nice for writing interactive scripts.
How to do that in Cygwin I wouldn't know, the above quote is from a real linux distro (package for Slackware, to be exact).
 
Old 10-23-2019, 05:54 AM   #5
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
thanks sir
 
  


Reply

Tags
ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running SPAN protocol on ns2 !! errors !! Hi, I am trying to SPAN protocol on ns2.28 using cygwin on windows 10 phyotay3 Linux - Wireless Networking 2 10-23-2019 09:11 AM
configuring cygwin properly after installation of cygwin in Windows 8 rupeshforu3 Linux - Desktop 1 06-07-2017 01:51 PM
[SOLVED] cygwin syntax random error during loop (how to reset cygwin?) fabriba Linux - General 11 07-29-2016 05:04 AM
[cygwin] How to use the cygwin.dll in Windows Programming Predatorian Programming 3 07-25-2014 11:45 AM
Running Cygwin on Windows 7 trying to compile and run THC Hydra ArrizX Linux - General 5 11-12-2009 10:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 06:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration