LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 05-08-2005, 10:56 AM   #1
Orkie
Member
 
Registered: Mar 2005
Distribution: Breezy Badger
Posts: 248

Rep: Reputation: 30
Gentoo - What depends on KDE?


I recently allowed portage to update my KDE to 3.4 (which is currently masked) and have since removed KDE 3.3.
Today I ran 'emerge --update --deep --pretend world' and it said it would be installing kdelibs-3.3.2. Is there a command I can run to see what is depending on this so that I can fix it?

Thanks
 
Old 05-08-2005, 02:48 PM   #2
davecs
Member
 
Registered: Feb 2003
Location: Barking, Essex, Britain
Distribution: PCLinuxOS and MX-Linux
Posts: 502

Rep: Reputation: 32
Have you used the "old style" kde upgrade or the "kde-meta"?

I would guess that until kde 3.4 goes stable this may be a problem. But I used the "meta" and I have had to add these lines to /etc/portage.keywords to stop the same thing happening:

Code:
kde-base/kpackage ~x86
=kde-base/kdelibs-3.4.0 ~x86
 
Old 05-08-2005, 03:33 PM   #3
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You need to "emerge gentoolkit". Then to get the packages that package "x"requires, do "equery depgragh x". If you want to see what depends on "x",do "qpkg -I -q x"
 
Old 05-09-2005, 02:22 PM   #4
Orkie
Member
 
Registered: Mar 2005
Distribution: Breezy Badger
Posts: 248

Original Poster
Rep: Reputation: 30
Thanks for those replies. I eventually worked out what was going on. I needed to unmask every KDE package that I had installed and I had forgotten to unmask some like kdeadmin etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSSH Server Depends DrWorm Linux - Software 0 07-17-2005 06:26 PM
plz, I really need some help with this, my job depends on this (TrendeNet adapter) Asagath Linux - Wireless Networking 9 12-22-2004 06:06 PM
Can't install OpenOffice.org - depends on libxpcom.so azebuski Linux - Software 1 02-29-2004 03:03 AM
URGENT!: vsftpd chroot config wont take changes. Major business depends on this. Help CrewXp Linux - Newbie 5 01-02-2004 07:27 PM
webmin module raid depends on fdisk toovato Linux - General 1 08-04-2003 02:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 11:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration