-   Linux - Distributions (
-   -   Gentoo grub error 15 (

bneal 07-27-2007 03:37 PM

Gentoo grub error 15
I just tried installing gentoo for the 1st time
I have it installed in VMware 8GB virtual-drive
partitioning (as I can remember it, I'm not at this machine now)
/dev/sda1 /boot 32MB --> boot flag set
/dev/sda2 swap 512MB
/dev/sda3 / 7.5GB

did the minimal install of Gentoo 2007.0
when I rebooted the grub menu came up but when I choose an option I get error 15

here is my grub.conf (as I remember it)

default 0

timeout 10


title=Gentoo Linux 2.6.19-r5
root (hd0,0)
kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/sda3

title=Gentoo Linux 2.6.19-r5 (rescue)
root (hd0,0)
kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/sda3 init=/bin/bb

I've only worked with some of the "easy" distros like Ubuntu, SuSE, Fedora, ect
so I've always had the installer do all this for me, but I'm trying to learn more about the behind the scenes type stuff
and yes I did RTFM but I'm not sure that grub is the issue so I don't know what the next place to look would be
help, please, I'm still very much a :newbie:

mcmillan 07-27-2007 06:48 PM

the error 15 message means some file that it's looking for is missing. The first thing I'd look at is to doublecheck that everything is spelled right.

I'm not sure but I think that if you have boot as it's own partition than for the kernel you just put /kernel-2.6.19-gentoo-r5, /boot/kernel-2.6.19-gentoo-r5 is if /boot is a directory on your root partitition

Lunate 07-28-2007 05:06 PM

There is a symlink in /boot called /boot that links to /boot (or . really), so the grub configuration file is correct.

The only advice I can give you on the error is to unplug the usb harddisks, if you have any.

bneal 07-31-2007 11:51 AM

ok I must have been at the KB too long cause I went over it about 10 times and could not find the problem
I left it alone for a day went back to it and BAM there it was a typo in the kernel line


All times are GMT -5. The time now is 10:20 PM.