LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   gentoo -- grub.conf is a read only i need help soon please (https://www.linuxquestions.org/questions/linux-distributions-5/gentoo-grub-conf-is-a-read-only-i-need-help-soon-please-126455/)

Laptop2250 12-16-2003 07:19 PM

gentoo -- grub.conf is a read only i need help soon please
 
I want to install gentoo and everything is going fine but I when i was up to the very last part!! (I did stage 1, so there were 23423 printed pages and setting up grub seems like the last page)

I have the following set up....
Windows XP- /dev/hda1
Linux boot- /dev/hda2
Linux swap- /dev/hda3
Linux root- /dev/hda4

I followed everything in the gentoo install perfectly and everything worked like it the manual said it should should, but I am not allowed to save the nano -w /boot/grub/grub.conf file.

To try to solve this I tried to overwrite the original grub by doing:
emerge -k grub
but this gave the error "emerge is not a command"

I am at a friends ocmputer, and would really appreciate any help somebody could give me on this subject

XavierP 12-17-2003 03:11 PM

Quote:

I have never used Gentoo, but I would say that "emerge is not a command" means that emerge is not installed, either fully or at all.

Or that you need to do it all as root.

Laptop2250 12-18-2003 06:36 AM

I was root, and several times during the install I used emerge program

Zerodark 12-18-2003 12:35 PM

If you are in the process of installing it, and it gave you that error you need to run this command before you can use the emerge command:

Code:

chroot /mnt/gentoo /bin/bash
If you already have Gentoo installed, then change the permissions on the file, so root can edit it.


All times are GMT -5. The time now is 08:14 PM.