-   Linux - Distributions (
-   -   Friggin Annoying Gentoo Install Problems (

Goatdemon 03-19-2003 11:46 PM

Friggin Annoying Gentoo Install Problems
ok, ive tried installing it twice from a stage one install with the newest release .... rc_14.3 or something... and i keep gettin screwed! after the 3 hour install (both times) i get an error at the first boot
mounting /proc ... oops
the mount command failed with error:
line 1 : mount: command not found

then it prompts for the root password to give maintanance
so i enter it and it says login incorrect... i know i reset the password... i reset it once on the first install then i did it twice on the second install ( i reset it at the beginning.. where it prompts ... and at the end to make sure it worked... it didnt)

furthermore, in section 19 of the install manual i printed out, it says to reset the password, i couldnt do it at this stage, it said command not found so i proceded to section 26, did "exit" then changed the password with "passwd" and it worked.. so i thought. then i unmounted and rebooted.

i think the proc problem may be fixable in my fstab file, but i cant get to it because it wont accept my password for maintinance... what can i do other than try that long ass install a third time?

...ah 1.4 rc3. that's it.

busbarn 03-20-2003 02:23 AM

I never got that error but I got some other bizarre errors because I accidentally skipped a step in the install. I'm not a guru so I would say you have to start over...or just download 1.4 rc2 that is already optimized for your machine. That would save you tons of time.

Goatdemon 03-21-2003 03:33 AM

fdjkld!!!!!!!!!!! i've tried installing 4 times !!!! 4!!!! and still the same errors... what the hell is the problem? it wont take my password for maintance, every lilo boot disk i make chokes out saying invalid compressed format, what can i do? what is there to do... and if one of you gentoo FU3$#@$'s tells me that gentoo is just to hard for me im gonna beat you to death! Why will it not work? i followed the friggin install guide to the letter.

crashmeister 03-21-2003 04:20 AM

Try the rc1 install with a stage3 tarball.There has been issues with rc2 and I don't know if anybody bothered to fix them.Also with stage3 you won't have to compile the whole thing to see it fail until you figured out what is wrong.Plus you don't need to install it again all the time anyway.You can always use the livecd to boot and chroot into the install.Check if /bin/mount exists at all.

Goatdemon 03-21-2003 01:01 PM

thank you! i will :)... finally advice

Goatdemon 03-21-2003 01:24 PM

i tried chrooting, doing the same thing the manual says
chroot /mnt/gentoo /bin/bash .... but /bin/bash doesn't exist
so i did chroot /mnt/gentoo / ..... permission denied
chroot / worked .... is this what i should be typing?

anyway,after i chrooted i saw that there was a mount in my /bin folder but when i rebooted, got the mount error (noticed that the post said EXT3 file system mounted .... or something to that effect) /proc wont mount, got the same password error (login incorrect) hit enter a couple of times and it sent me in to a bash shell which allowed me to check out the hard drive (cant modify it.. read only) and checked the /bin directory only to find no mount. the only command i can get to work is emerge and it cant modify anything on a read only fs.

acid_kewpie 03-21-2003 01:34 PM

if you're not getting even anythign at all in the bin directory then you definietly typing something wrong, i'd guess you are not decompressing the stage1 tarball correctly. check the installation docs properly

crashmeister 03-21-2003 01:42 PM

You need to mount the file systems first as described at step 7 - just mount them and then try to chroot over.
Don't remember if you'll need to do all the steps under code listing 8.3 either - except to copy /etc/resolv.conf - it's been a while.
I'd try it myself if I could find my install CD.

Goatdemon 03-21-2003 04:38 PM

acid the /bin directory does have some files in it, just not mount.
and ill try again

Goatdemon 03-21-2003 09:45 PM

ok, ok im making progress i somehow got the password to change but now i'm having a problem ...
modprobe cannot locate module devfs
i did have it compiled into the kernel from the beginning but i went to see if i could make it a module to fix the problem only to find that there's no module option for devfs. can i modify a file to fix this? if so which one.

i recompiled the kernel once again and the problem didn't get fixed.

monkeymartin 03-21-2003 10:07 PM

this is a good link for a person new to gentoo

Goatdemon 03-22-2003 04:05 PM

anyone... ?

crashmeister 03-22-2003 10:15 PM

I can't help you there aside from the fact that you need to enable devfs and enable at boot.I usually don't use modules,don't like them,don't mess with them and don't know how to.

Goatdemon 03-23-2003 04:23 AM

ok... i reinstalled again and i have different hopefully more easily solvable problems

i boot gentoo and get this...
ds: no socket drivers loaded!
ext3-fs: mounted files system with ordered data mode
vfs: mounted root (ext3 fs) readonly
mounted devfs on /dev
freeing unused kernel memory

... from here everything is read only again so i cant change anything, install anything... do the necessary things of an operating system. do i just need to make my ext3fs writable? if so how do i do it? i dont get anything that looks like an error other than that ds line with the exclamation point at the end. doesn't ask for the root password or anything. what's the problem now?

crashmeister 03-23-2003 05:04 AM

Do you got an extra /boot partition or only / ?
My log looks the same with the exception that my /boot is ext3 and after it mounts that read-only it mounts the reiserfs which is / .

All times are GMT -5. The time now is 06:44 PM.