-   Linux - Distributions (
-   -   F***ed my gentoo. (

jollyjoice 06-08-2006 01:12 PM

F***ed my gentoo.
Ok, Trying to upgrade to the new xorg 7.0 and it's all gone tits up.

I now have no X, and can't log in, and now python has died.

Tried to reinstall old 6.9.0rsomething and now X fails to load.

Login prompt, enter user name and hit enter, no "password:" prompt, or anything at all, ctrl+c gets me back to login prompt but no user can login.

Booting ubuntu live cd to get 64bit environ, can chroot into system, however python has now thrown it's toys out the pram.


Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]

!!! Failed to complete python imports. These are internal modules for
!!! python and failure here indicates that you have a problem wit h python
!!! itself and thus portage is not able to continue processing.

!!! You might consider starting python with verbose flags to see what has
!!! gone wrong. Here is the information we got for this exception :
No module named fcntl

Traceback (most recent call last):
File "/usr/sbin/env-update", line 28, in ?
import portage
File "/usr/lib/portage/pym/", line 20, in ?
import os,string,types,signal,fcntl,errno
ImportError: No module named fcntl

Any help very welcome.


oneandoneis2 06-08-2006 02:04 PM

Tried logging in to the single-user, non-graphical runlevel?

jollyjoice 06-08-2006 02:34 PM

nope, I'm missing any login software it seems, i need shadow, but python isn't playing nice so I can't use portage to install it... Trying to get portage working again 1st, work from there I think.

Wolfgang Dobler 06-30-2006 11:55 PM

I just had a similar

Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
problem after trying to upgrade to x11-7.0 on x86_64 (and 7.0 is now marked as stable -- most likely by accident...).

The reason was that something (some component of x11, I guess) screwed up /usr/lib64. This should be a link to /usr/lib,

/usr/lib64 -> lib
but after the failed installation it was pointing to /lib64.

40 minutes later...
It was actually x11-base/xorg-x11-6.8.2-r8 that screwed up the link, just before being done with the installation. I am currently installing x11-base/xorg-x11-6.8.2-r7 to see whether that is better.

Another hour later...
That did not make a difference. I have no clue why 6.8.2 would now try to do something stupid and choke on it if it installed perfectly fine the last time.

So I am now going for a binary package from another machine (as I was too stupid to make one on this computer).
Three minutes later...
This did the job.

jollyjoice 09-05-2006 12:13 PM

Hey, nice to see you got it working.

I gave up in the end and tried that fancy new gui installer :D

All times are GMT -5. The time now is 09:17 PM.