LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Emerging GNOME in Gentoo Linux (https://www.linuxquestions.org/questions/linux-distributions-5/emerging-gnome-in-gentoo-linux-54801/)

qulnxsh 04-13-2003 03:32 AM

Emerging GNOME in Gentoo Linux
 
Hello,
I've been trying to install Gentoo, and so far I've emerged everything but some GNOME packages. When I try to do so, I receive the following message:

Calculating dependencies ...done!
>>> emerge (1 of 5) media-libs/libao-0.8.3 to /
>>> md5 libao-0.8.3.tar.gz
>>> Unpacking source...
>>> Unpacking libao-0.8.3.tar.gz to /var/tmp/portage/libao-0.8.3/work
>>> Source unpacked.
/usr/sbin/ebuild.sh: line 20: cd: /var/tmp/portage/libao-0.8.3/work/libao-0.8.3-r0: No such file or directory

* Cannot find $EPATCH_SOURCE! Value for $EPATCH_SOURCE is:
*
* /usr/portage/media-libs/libao/files/libao-0.8.3.patch


!!! ERROR: media-libs/libao-0.8.3 failed.
!!! Function epatch, Line 214, Exitcode 0
!!! Cannot find $EPATCH_SOURCE!

I only have about 5 packages left, but I need to get libao-8.3.0 installed to finish emerging GNOME. Has anyone gotten around this problem (this might be a bug)? I would greatly appreciate any help. Thank you

yngwin 04-14-2003 03:06 PM

You seem to miss a patch file that should be in the portage tree. I suggest you do an emerge sync and try again.

acid_kewpie 04-14-2003 03:08 PM

the /var ebuild path looks dodgy with the -r0 on it too. rsync, and also maybe try emerging a newer ebuild if there is one. might need to used a masked build, but that should't matter.

ACCEPT_KEYWORDS="~x86" emerge -p libao

neenee 04-14-2003 03:13 PM

also, try the wonderful forums at gentoo.org

qulnxsh 04-15-2003 01:05 AM

Hello,
Thank you all for the assistance, I issued emerge sync and that fixed the problem. Now I'm getting used to the...blazing speed I might say.

Bye


All times are GMT -5. The time now is 09:58 PM.