LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 01-15-2015, 10:33 PM   #1
MunkyCheez
LQ Newbie
 
Registered: Jan 2011
Distribution: Xubuntu (XFCE)
Posts: 5

Rep: Reputation: 0
/dev/-related errors, "Filesystem Check Failed"


Hello community,

I'm trying to get crux 2.8 up and running and I've always run into some issue or another. Usually, it involves a kernel panic along the lines of "VFS: not syncing", which I thought I narrowed down to an ATA/IDE driver issue with the kernel but never was able to solve it despite my attempts. I decided to give it another go on a different (but similar) machine:
  • Dell Inspiron B130 (laptop)
  • Pentium M
  • Intel GMA integrated graphics
  • IDE hard drive
Here's what's going on:
Code:
LILO Loading crux..................................
BIOS data check successful
EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
EXT4-fs (sda1): couldn't mount as ext due to feature incompatibilities
INIT: version 2.88 booting
The system is coming up. Please wait.
mount: unknown filesystem type 'devtmpfs'
cannot open /dev/null
udevd[970]: cannot open /dev/null

udevd[1004]: open /dev/null failed: Read-only file system

udevd[1003]: open /dev/null failed: Read-only file system

error: /dev/loop0: No such file or directory

[...]
...and the messages continue. I guess the /dev/ tree isn't being created. After more /dev/-related messages scroll by, I see:
Code:
********************* FILESYSTEM CHECK FAILED ***************************

Please repair manually and reboot. Note that the root file system is currently mounted read-only. To remount it read-write type: mount -n -o remount,rw /
When you exit the maintainance shell the system will reboot automatically.

*******************************************************************
Initially I thought this was due to devtmpfs being excluded from the kernel. Sure enough, it was. I changed my .config as follows:
Code:
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
(just to be safe). Recompile kernel, and still the same thing.

/etc/fstab
Code:
/dev/sda1       /               ext4         defaults         0     1
# I tried with the following line commented and not commented, still errors:
#devpts         /dev/pts         devpts      defaults         0     0
/etc/lilo.conf
Code:
lba32
install=text
boot=/dev/sda
image=/boot/vmlinuz
   label=crux
   root=/dev/sda1
   read-only
   append="quiet"
/etc/rc.conf
Code:
FONT=default
KEYMAP=us
TIMEZONE=UTC
HOSTNAME=b130
SYSLOG=sysklogd
SERVICES=(net crond)
P.S. Something definitely going on with the /dev/ tree. Check it out:

ls -A /dev
Code:
console   initctl   null   pts   shm

Last edited by MunkyCheez; 01-15-2015 at 10:34 PM.
 
Old 01-17-2015, 04:05 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Code:
EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
EXT4-fs (sda1): couldn't mount as ext due to feature incompatibilities
It looks like
1. You didn't load the initrd when you needed to, or
2. Your kernel is incorrect, lacking ext4 support. Filesystem support needs to be compiled into the kernel or supplied by an initrd.
 
Old 01-18-2015, 01:11 PM   #3
MunkyCheez
LQ Newbie
 
Registered: Jan 2011
Distribution: Xubuntu (XFCE)
Posts: 5

Original Poster
Rep: Reputation: 0
Hey, business_kid. Thanks for your reply.

Quote:
Originally Posted by business_kid View Post
2. Your kernel is incorrect, lacking ext4 support. Filesystem support needs to be compiled into the kernel or supplied by an initrd.
I think I had this part right:

$ grep -i ext4 /usr/src/linux-3.5.4/.config
Code:
CONFIG_EXT4_FS=y
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXT4_FS_XATTR=y
# CONFIG_EXT4_FS_POSIX_ACL is not set
# CONFIG_EXT4_FS_SECURITY is not set
# CONFIG_EXT4_DEBUG is not set
Quote:
Originally Posted by business_kid View Post
1. You didn't load the initrd when you needed to
I think I understand the basic concept of what initrd/initramfs does, but I don't know how to even begin troubleshooting this aspect. What would you recommend? Thanks.
 
Old 01-18-2015, 02:01 PM   #4
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
The basic concept of an initrd is that it loads on / and supplies kernel modules. Useful for distros trying to cater for all types of systems. When you mount the / filesystem, on / you mount over the initrd and it vanishes. Modules then used are your ones in /lib/modules. You only need an initrd if you need extra modules on bootup.

This is a better line for /dev/pts
Code:
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
Now, presuming that fixes nothing, your error is
Code:
EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
EXT4-fs (sda1): couldn't mount as ext due to feature incompatibilities
Which tells me there are extra features enabled on your ext4 system (maybe ACLS?) that you have no support for. That is unusual if a distro install made the ext4 partition, and supplied the kernel. If this is a home built kernel, bets are off. It may be a disk fault. Can you fsck it?
 
1 members found this post helpful.
Old 01-18-2015, 10:38 PM   #5
MunkyCheez
LQ Newbie
 
Registered: Jan 2011
Distribution: Xubuntu (XFCE)
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by business_kid View Post
The basic concept of an initrd is that it loads on / and supplies kernel modules. Useful for distros trying to cater for all types of systems. When you mount the / filesystem, on / you mount over the initrd and it vanishes. Modules then used are your ones in /lib/modules. You only need an initrd if you need extra modules on bootup.
Okay, so if I understand correctly, I don't necessarily need one in this case, becase (I think) all necessary features are included in the kernel and not in loadable modules.

Quote:
Originally Posted by business_kid View Post
This is a better line for /dev/pts
Code:
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
Okay, changed. Same result.

Quote:
Originally Posted by business_kid View Post
Which tells me there are extra features enabled on your ext4 system (maybe ACLS?) that you have no support for. That is unusual if a distro install made the ext4 partition, and supplied the kernel. If this is a home built kernel, bets are off. It may be a disk fault. Can you fsck it?
Assuming "ACLS" is the same as "ACL" in my last post, it is not enabled (see the snipped of my .config. It is indeed a homebuilt kernel. I booted off a CD and ran fsck, and everything seems alright as far as I can tell:

# e2fsck /dev/sda1
Code:
e2fsck 1.42.5 (29-Jul-2012)
/dev/sda1: clean, 77116/4890624 files, 66782/19537430 blocks
I am starting to wonder if this is actually a hardware issue, since I tried the same install on a handful of other similar systems and they had a different error (pretty much the same result on all the rest, except this one). I'll try a different distro on here and see how it behaves with disk access. Thanks for your help.
 
Old 01-19-2015, 04:57 AM   #6
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Code:
# e2fsck /dev/sda1
That only does something if the disk was unclean. Try this

Code:
# e2fsck -fvy /dev/sda1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6: "mount: could not find filesystem '/dev/root'" sancho Fedora - Installation 17 09-02-2016 12:42 AM
[SOLVED] How can I use a USB stick to back up my files... I keep getting "root"-related errors OmegaD Linux - Newbie 1 02-10-2012 07:44 PM
CentOS "mount: could not find filesystem '/dev/root'" newDevlp Linux - Kernel 3 02-04-2012 04:51 AM
[SOLVED] Slackware won't boot "/dev/sdc1 contains a filesystem with errors" vttay03 Slackware 4 01-15-2010 08:41 AM
FC6: "mount: could not find filesystem '/dev/root'" cheerful Fedora - Installation 2 07-27-2007 03:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 12:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration