LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 02-22-2008, 07:11 PM   #1
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474
Blog Entries: 28

Rep: Reputation: 34
Corrupted output from manpages


I am getting the following output from my manpages. I'm using Gentoo, with lzma compression on the pages. I don't know if this has been dealt with before (probably has), but I need a quick solution to this.

Shingoshi

The same thing happens with using info, too! Just found that out.

====================================================
]oz'mrAE7/I7#x(*.3~U....V.c:1/4t2oirUuHcxS(C)TOe|aeecY|+-AaF/OjOO}gl+dAEK<<UOUe9/u|2 uE* .I[EIy|c....
(R)yEG()Wx1/27_bdAh_eo+uAMcKS9~Y/)R ipNOquxoFyHiI1/4CNxxsO|yONE/qReh hUACu7aXw9|uOa8uxc[cu$OH^~=!A3u%HS='*
'Zpa>O+N4I@D SIiA|oIKAUuUZTixOL<w& oUsSeOcUFI1ouYOeOI.a1/4lfBADuy>>ap9bO uxx)Ym ~1a<<Y-:-F|BY4oYrA;da%bi |ma8w(+u,jhxH|a^-
,A-:-oxNDrudi5SoJ*3/4LeAx QcUEAfOOA33i....(C)Sq1o1/4bdeuibA<<[eifu(C)+-U1/4ENUo"#%:F<aOi[AKC%u[(R)oNBI!1Ba1/47@U-Lh<<8=|( L3'ZODa.O+-eE*AowiAu2(C)~aia0uGV<<xoea#H-:-MS YOmEUeo[J~^oo<cL,ITvA.....Ygx6IOQ1Y51hcIo[i=nfiecooeEb
Y',aeb'->>aAci|~Os1/2YjeHX?MJuy&.V?Y=_-;o(aYoYoF;+-IyOa(C)p;e=oOE]y+-+Sv ;QLoa~.o6oaE&FZ-:-o9|WU
I9,n 5u8u,qiuu.qo)[-Ooqo1uaqA7SLHVe..&Ov"o0EeVoCx^@tIecEOlA;O>>AEk}"EOPDu}E9q7)AOSF?x)c8iT%]cB~?@A,+-<<b1/2c[61/4nPe[BwoOCbO &Zo8I3%1/4u10u'A
ce0n,%Gae`.ajN%gEk2R0L~Y(C)n+Xy3/4eAE2 aOgA?-:-x}IyDiONaD+O1b&A5*@9|iUoxCE e +-DWiAEEcaGcAE*S~,e
".......ZOCXr(R)5iU8ni>>4`keP!ACaqa[AEAyOoF*BT(C)uBoYaeC^"eeOoEuO3cg8ibaoNEiPi3+-.+-n,5eAMli_LV1#IMZAY~^LE={uCLPkh2,:C"(|(ibioOxOi%EA+-i_x2pc{N+
uApTj8;9EDMeBs1/4#Q5O|U`P[+c i+-o@uToY.-:-cNeo>>0oIo;i0>>HeEo3/4BtMEa>>>c^1/4mIi(R)C2U el) TEA32'aPixo<<A NBxCoIo|i(R)YUgBy^zb^qu|2v'bePOu[,-
ikUYGoi1/2!o] Spul=j2^i=,Qa<E1nOOaIA,c7 Rae'?PICo~eSBuION]Oy3/4O@<<Np" !*Uc)Uonzuui)'a6u=Yay(R)o>n+-SB7ffCtNA!x o>oxUab,9a(R)aXk(R))xoOu+ i
!3/4 aaIc,uaiG2qMoPI _
tl'y7!oCoHgvo.AA^aO ePV2LUw@uyaehY6o;mAEae.JiB,yfU~Ni;-:...EAeoUU#iv.YoyYAYiOl12uo}AaOui3hWxAi<<k8IuI(C-:-orp| <<Zc"eooN;Ao#EH"i(Da!iCVK-I2L!1/4Ey<<A`!AUaae"CHGAbaE]UU8~A8U>TH' XVAkOeah<<HS;i>rS9|qYAaT$IZoF|~exa
cT.CIxFuEOs^1/42iA@qe V;V3/4B9|4ulUIu,<<q4o-'BNo[i,Gc;+PaVr$Lq$O ALxE+9|}uUBAtWE-:-Yau9|t4*kD^>>6Yd&du:e@^anTpS..u3yU-
A>(C)|UAIu$%AUsayyoK}%}aO"A+|*d"o-:-UaOxQOUOirsaOuyi$i.O.Jq1l~ixo.Icu3......uAAIgaau!oC9=x^i0VAY3iA<<"aEO-:-gk,<-:-xIa"@vY2a'noxI'7WlQ bOlAv.yOPofYa2nn,OatakY>uIiid`w<<u2
&U9|-IHU1/2O2:sO91/29.o1/4^(C)UEP|L;>>AEb Cap <<1/4EDBp74.aOV'oI3/4,^_iVfoi/LeCio69|Oo4DcUx3o`uUaKl;OeL5AYZ,|IMyxn3O5
6AkU61/4i:[cmUaYua&3o}wDOe1arxFyEiI,|Uh")<<ZAI..CXuIeAPi1Amab v&waUBOD. H2088|'zxhA`OLUboi;-_ M
KAXL+uAE-:-x)#2u,roxTBEAn{FaUa|iae<NAEcIOUxC3-|bEaan{UbA:n`(R)UO' VU1|2/9*u*#Ix@si......tEeoLm4/oAob',"I'aco.A}3(C)oodW>Ci|vaEIaYuLgo:nHaezVG1-

Last edited by Shingoshi; 02-22-2008 at 07:21 PM.
 
Old 02-22-2008, 07:22 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
Did you recompress the manpages? I've only seen manpages with .gz extentions. Does "less /path/to/manpage" show the troff source? The man command normally uses the less program for it's pager. Look at the value of your PAGER environment variable. That is the pager that your man program uses. If there is a pager that displays text with lzma compression, then changing the PAGER variable in your ~/.bash_profile or ~/.bashrc may fix the program.
 
Old 02-22-2008, 07:38 PM   #3
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474

Original Poster
Blog Entries: 28

Rep: Reputation: 34
The compression format of manpages can be changed in make.conf

Quote:
Originally Posted by jschiwal View Post
Did you recompress the manpages? I've only seen manpages with .gz extentions. Does "less /path/to/manpage" show the troff source? The man command normally uses the less program for it's pager. Look at the value of your PAGER environment variable. That is the pager that your man program uses. If there is a pager that displays text with lzma compression, then changing the PAGER variable in your ~/.bash_profile or ~/.bashrc may fix the program.
The variable for doing it is:
PORTAGE_COMPRESS="lzma"

I need someone to tell me exactly how to recompress the manpages, since I don't have a manpage which I can read to tell me. So I need the exact command(s, in proper order) to eliminate this problem.

Shingoshi
 
Old 02-22-2008, 09:09 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
Is that the default value for that variable. If so, check the value of the PAGER variable. It probably will be "less". If it is "less", then check the value of your "LESSOPEN" environment variable. The LESSOPEN variable should contain the name of the program that less uses to analyse the file and uncompress it using the correct program. That program will create a temporary file. The environment variable LESSCLOSE will contain the name of a program that deletes the temporary file.

If you recompress your man files, you will end up doing so for new packages.
 
Old 02-23-2008, 11:28 PM   #5
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474

Original Poster
Blog Entries: 28

Rep: Reputation: 34
(I thought) I've solved this myself...

I had previously given instructions on how I thought I had solved this. But the situation REMAINS.

I originally got a complaint about:

man emerge
fgets: No such file or directory
Error reading man page /usr/share/man/man1/emerge.1.lzma

Changing the settings in /etc/man.conf had NO effect on this whatsoever. The situation remains. It seems that unless an instruction exists, to recompress existing man-pages to another type, the only solution is to rebuild all packages with "emerge -e system or emerge -e world". I haven't tested either of these yet, so I don't actually know.

Xavian-Anderson Macpherson
Shingoshi

Last edited by Shingoshi; 02-24-2008 at 12:45 PM.
 
Old 02-24-2008, 02:16 PM   #6
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474

Original Poster
Blog Entries: 28

Rep: Reputation: 34
I'm still researching this for a fix.

I came across this in my searching:

Following emerge =dev-java/blackdown-jdk-1.4.2.03-r13, the man pages installed
in /opt/blackdown-jdk-1.4.2.03/man/man1/ (and any localized man pages) are
doubly compressed as .gz.bz2 files, which the 'man' command cannot handle
properly.

Reproducible: Always

Steps to Reproduce:
1. emerge =dev-java/blackdown-jdk-1.4.2.03-r13
2. ls -l /opt/blackdown-jdk-1.4.2.03/man/man1
3. man -M /opt/blackdown-jdk-1.4.2.03/man

I don't know if this applies to me or not. I did recently attempt to install blackdown, though
unsuccessfully. Some pages are properly visible, and others are not. I think man is attempting
to use lzma when reading old .bz2 pages. That's not correct, and should never happen.

Shingoshi
 
Old 02-24-2008, 02:59 PM   #7
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474

Original Poster
Blog Entries: 28

Rep: Reputation: 34
This is happening with newly installed packages.

That being the case, it doesn't seem that running "emerge -e system" would make any difference, since if this happens with newly installed packages, rebuilding them would likely yield the same result.

Shingoshi
 
Old 02-26-2008, 05:29 AM   #8
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474

Original Poster
Blog Entries: 28

Rep: Reputation: 34
I can happily say I was wrong.

Running "emerge -e system" did resolve the situation. At the end of doing so, I found out I had not properly set the (de)compression for lzma in /etc/man.conf.

Here are the correct settings:

COMPRESS /usr/bin/lzma
COMPRESS_EXT .lzma

# Decompress with given decompressor when input file has given extension
# The command given must act as a filter.
.lzma /usr/bin/unlzma -c -d

Shingoshi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Inserting Manpages bhandu Linux - Software 2 03-20-2006 10:25 AM
Help! Hard drive corrupted (dmesg output) apachedude Linux - Hardware 3 02-04-2006 11:07 PM
NPTL manpages vghiware Programming 1 09-19-2005 10:58 PM
manpages not working plosiv Linux - General 1 11-11-2004 10:57 AM
more about manpages bigjohn Linux - Newbie 1 03-04-2004 09:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration