-   Linux - Distributions (
-   -   Another question about nfs and openldap in centos 6.3 (

gaby 08-23-2012 11:57 PM

Another question about nfs and openldap in centos 6.3
Hi everyone. I have one server configured with openldap for authentication and an nfs export. All client servers can authenticate successfully and the nfs export is seen with the correct ownership. I have another server that also exports another nfs. This second nfs when mounted in another server shows the nobody:nobody ownership. When check the /var/log/messages it shows the following messages "nss_getpwnam: name '507' does not map into domain 'my_domain'.
server_a: exports /nfs1 and has openldap
server_b: exports /nfs2 and authenticate against server_a and mounts /nfs1 with correct ownership
server_c: authenticate against server_a, mounts /nfs1 with correct ownership, mounts /nfs2 with nobody:nobody

Thanks in advance

gaby 08-24-2012 03:14 PM

After a lot of searching finally made a modification that solved my problem. I followed this tutorial and it worked. Now I am still trying to figure out what was exactly the problem. I think it had to do with how I had the /etc/nslcd.conf file

All times are GMT -5. The time now is 05:29 AM.