LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   [gentoo[not specific]] didn't manage using initrd (https://www.linuxquestions.org/questions/linux-distributions-5/%5Bgentoo%5Bnot-specific%5D%5D-didnt-manage-using-initrd-339902/)

MD3 07-04-2005 11:04 AM

[gentoo[not specific]] didn't manage using initrd
 
Hi!

I've just recompiled my kernel in order to use a ramdisk to make fbsplash work.
I've read "man lilo.conf" and "man initrd", i've recompiled the kernel enabling the ramdisk support (Device drivers > Block devices > <*> RAM Disk Support) (Device drivers > Block devices >[*] Initial RAM Disk Support), i've modified lilo.conf in this way:
Code:

### MAIN ###
boot=/dev/hda
prompt
delay=1200
default=Gentoo
#vga=ask  #Made obsolete by vesafb-tng
password=xxxxxxxx
restricted

### GENTOO ###
image=/boot/bzImage
label=Gentoo
read-only
root=/dev/hda1
append="video=vesafb,ywrap,1024x768-32@75 quiet splash=silent,theme:gentoo"
initrd = /boot/fbsplash-gentoo-1024x768

### MINIX 2.0.4 ###
other=/dev/hdb2
  label=Minix
  table=/dev/hdb

but, at boot-time, i get this error:
Quote:

Kernel 2.9.11-gentoo-r11 wrote
VFS: Cannot open root device "301" or unknown-block(0,0)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

if i don't use initrd the system boots normally.


wtf can the problem be??


thanks eb ;)


All times are GMT -5. The time now is 08:47 PM.