-   Linux - Desktop (
-   -   xfce4-sensors-plugin does not display hddtemp (

wpost 05-22-2010 12:39 PM

xfce4-sensors-plugin does not display hddtemp
On my box, xfce4-sensors-plugin sees lm_sensors data but not hddtemp data. Googling, I see reports and screenshots of it working with hddtemp, so it does work for some users. Yes, hddtemp is installed, the daemon is running and launches on boot, and works:

$ hddtemp /dev/sda
/dev/sda: ExcelStor Technology J8106 S: 35C

Per the xfce4-sensors-plugin developer's recommendation, hddtemp is suid root.

I've downloaded the xfce4-sensors-plugin source code, read the enclosed notes re: hddtemp not showing, and have even compiled my own -- which also sees lm_sensors data but not hddtemp.

My box is mdv2008.1, 2.6.26, Xfce 4.4.2. I've tried two versions each of hddtemp (-0.3-0.beta15.8mdv2008.1 and -0.3-0.beta15.8.1mib2008.1) and xfce4-sensors-plugin (- and one I rolled myself from source with checkinstall).

Has anyone successfully gotten xfce4-sensors-plugin to see hddtemp data? How did you do it?

catkin 05-23-2010 05:15 AM

Are you starting the hddtemp daemon? If xfce4-sensors-plugin works like GKrellM then the hddtemp daemon must be running to generate the data. Here's an example command: /usr/sbin/hddtemp -d -l /dev/sda

wpost 05-23-2010 11:43 AM

Yes, the hddtemp daemon starts on boot, and is running:

# service hddtemp status
hddtemp (pid 4371) is running...

Conky sees it (the relevant line in my .conkyrc is "Temp: HD ${execi 10 hddtemp -n /dev/sda}").

As a plan B I may just give up on xfce4-sensors-plugin and instead use gkrellm (as you mentioned in another thread you do) or conky. But my preference is to economize on my monitor's real estate and have this and other hardware data in the Xfce panel, not on the desktop, hence my perhaps stubborn insistence in getting xfce4-sensors-plugin to work.

wpost 05-25-2010 07:27 PM

Not solved, but worked around: I gave gkrellm a try and it detected hddtemp and a whole lot more out of the box. So I've switched from xfce4-sensors-plugin to gkrellm. Thanks, catkin, for that lead.

All times are GMT -5. The time now is 09:33 AM.