-   Linux - Desktop (
-   -   XFCE4.4 Menu Panel Item taken out? (

1veedo 12-10-2006 04:53 PM

XFCE4.4 Menu Panel Item taken out?
I just emerged the latest xfce4 (3.99.2) and I cant find the panel item for the menu. I can right click and it shows up but unlike older xfce4s you cant put it on the menu. Is this an actual change or a bug I have?

I'm tempted to force emerge xfce4-panelmenu because that was (I think) the package for older xfce4s. They've changed the panel though and when you build xfce4-panel it builds all the modules/applets/items (whatever they are) so it might not be compatable.

Btw the lattest xfce4 is awsome! Make sure to install thunar and xarchiver. Now it has a file manager, an archive manager, and a little text editor (mousepad).

xpromisex 12-10-2006 07:29 PM

Are you referring to the "start" menu for Xfce4? I know you can add that to the panel as an app. Not sure why it isn't showing.

1veedo 12-10-2006 07:59 PM

Yeah, the start menu -- like when you rightclick the desktop. I guess it didn't get installed or something.

Maybe gentoo doesn't have a package for it yet.

xpromisex 12-10-2006 08:48 PM

have you checked for xfce-menu in the app listing? It may be different than what it was called before (Obviously, I'm bottom fishing here - don't take offense to my stupid question.)

1veedo 12-11-2006 07:35 PM

This may sound a bit odd but what package is it on archlinux? I could get it from an arch mirror. I already looked at xfce4-panel- and dont think it's in there.

Mathijs 01-17-2007 05:40 AM

I've found a workaround for the panel menu:
you can add a launcher (right click the panel -> add item -> launcher) and set the command to this:

xfdesktop --menu
this pops up your menu at the current mouse position


Spect 01-26-2007 08:44 AM

i've had the same problem when upgrading from to 4.4.0.

i unmerged several xfce ebuilds (xfce4, xfce4-panel, xfdesktop and such), renamed all the xfce configuration files (both in my home directory [.cache and .config] and in /etc/xdg/) and emerged xfce again. it crashed when i tried to log in, but xsession-errors told me that the xinitrc file in /etc/xdg/xfce4/ was missing, so i copied it back from renamed directory. then i could log in and the menu worked, so i moved back my .config directory, logged again, and successfully added the Xfce Menu.

it's some kind of bug in upgrades system..

Mathijs 01-27-2007 02:45 AM

I read somewhere on the web that the Xfce panel menu is now build together with the desktop. So when you emerge/compile/whatever your Xfce-desktop package, make sure you have "panel-plugin" as a USE flag.
re-emerging with that flag set solved my problem.


All times are GMT -5. The time now is 11:40 AM.