-   Linux - Desktop (
-   -   xfce: recreating my default session (

xri 06-25-2007 02:16 PM

xfce: recreating my default session
For some reason, my "default" session on XFCE has been messed up and comes with no background, no panel, no icons, no windows, etc.

What I did the first time I noticed it was:
  1. Start manually the panels, session, etc, until I had a real session.
  2. Then I chose the "save session on exit" option and also "chooser on login" option.

So now, when I log in, gdm presents me with two possible sessions:


I obviously choose the second and continue.

If I don't enable the "chooser on login", gdm sends me directly to the dud "default" session which is unworkable.

How can I restore/recreate a decent default session, so that I don't need the "chooser on login" option but instead, log into a workable normal session straight away?

Centinul 06-26-2007 06:59 AM

I'm not on my linux workstation right now so I can't give you the exact folder location but in your home directory there is a folder that contains information on XFCE sessions. It might be .xfce/sessions or something along those lines.

Once you find it do the following:
1. Log out of XFCE and stop X.
2. Login to a text only terminal
3. delete all the information in the sessions folder.
4. Start up XFCE and begin your new session.

Should be all set after that. I've ran into this issue before and it has worked like a charm.

Let us know if you need anything else. :)


xri 06-26-2007 06:49 PM

Brilliant, Centinul.

It was under .cache and it was easy to edit the file.

:) Thanks a lot for your help.

All times are GMT -5. The time now is 07:21 PM.