-   Linux - Desktop (
-   -   Xfce desktop disappeared (

Weapon S 07-21-2011 08:14 AM

Xfce desktop disappeared
Debian Squeeze. XFCE 4.6.2. (Clean install with xfce as desktop.) Noob. Using Dutch version (beware mistranslations.)

In the desktop settings only "none" and "minimalized program icons" were available. When I clicked the second option, all of my desktop options disappeared. After that I couldn't get any icons back, and also the default right-click menu stopped working. I can still get the "programs menu" on right-click, if I set the option. I've tried dpkg-reconfigure *insert a lot of xfce packages*. And a lot of xfdesktop --reload's...

I had moved some folders about, and that's the only cause I can think of. (I've moved them back, but it isn't fixed. I can't remember if I actually deleted some folders and than recreated them. The folders I'm talking about are the default 'document folders' f.i. "Downloads". I've seen configuration files reference them, but not yet the Dutch equivalents, which were apparently configured.) I'm trying to find every configuration file used by xfdesktop. A little help here, please.

ButterflyMelissa 07-21-2011 08:25 AM

Tried an uninstall and re-install?

Make backups first, but, you know this... :)


Weapon S 07-21-2011 08:30 AM

I thought reconfigure was basically the same thing as reinstalling. It seems to have affected my ability to switch to a virtual terminal, so there is definitely something messed up badly. (X server goes black after switching...)

TobiSGD 07-21-2011 08:32 AM

Before reinstalling, logout, move the folder ~/.config/xfce4 to another place and login again. See what happens.

Weapon S 07-21-2011 08:59 AM

That worked
:cool: Well, all of my wonderful customizations are gone. But at least the desktop is back again. :) That's a big relief. Thanks.
How can I use diff to pin-point the defect?
I want to find the culprit >:( Delete his ass! ) I've already tried to manually change those files, but not in drastic ways.

Also, I could switch between virtual terminals, but the default of a fresh xfce install is apparently to use the eighth thingy instead of the seventh. (So ctrl+alt+F8, instead of ctrl+alt+F7.)
I've found the file to edit to change the directories: ~/.config/user-dirs.dirs

:") OMG that's an easy to reproduce failure! (It happened again!) I can't imagine this is a known bug. (Nobody would leave something that big in!) There must be something else wrong... If there is something wrong in the config, I have at least a minimal difference set to compare to now.

TobiSGD 07-21-2011 09:26 AM

After login in again and seeing that there are no configuration files XFCE created a set of new files. If you now move a single file at a time from your old configuration folder to the new one you will found out which file contains the cause for your issues. If you then compare it to the standard file you should find the culprit. If not you can post the file here so that we can have a look at it.

Weapon S 07-21-2011 11:51 AM

First I replaced the good files with the bad files, to verify there wasn't another problem instantiated the moment I entered the config dialog. Then I ran diff -N -a -r ./xfce_clean ./xfce_minimal_error > diff_clean_error.txt, on two copies of the config folders I had made. (Speaks for itself.) The -N was necessary because it was a file that was not in the 'clean version', and -r is necessary to recurse into subdirectories. The first number in the "difference code" is the line number.
The file in question was ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.
In particular, the part that says:

  <property name="desktop-icons" type="empty">
    <property name="style" type="int" value="x"/>

x is 0 for no icons, 1 for show-minimalized-programs-as-icons, and 2 for show-normal-desktop-icons-and-menu

So the problem is, the GUI-dialog doesn't have an option for 2. Once you select something different, you can't set it back.

TobiSGD 07-21-2011 11:56 AM

Does it work when you manually set it to 2?

By the way, you should check your font and color settings, your post is difficult to read.

Weapon S 07-21-2011 12:41 PM

Yes it works :) ...not very cleanly. I'd love to see whether this is a known bug (that perhaps has been fixed in the new version), but I can't really search the forum-like bug-tracker efficiently. So this will do for now... I hope.
It could be just by a missing translation. But the translation file is .po gettext, so no manual editing...

htp 03-23-2012 07:42 AM

Not sure if this helps - but I also had the problem that my desktop icons vanished.

I didn't want to lose all my settings (by deleting/moving ~/.config/xfce4).

The solution was really simple - just restarting xfdesktop at the command line, logging out and logging back in.

I guess xfdesktop must have crashed in a previous session and then didn't start up in subsequent sessions.

rowol 10-23-2012 05:58 PM

I had the identical problem with XUbuntu 12.04/XFCE4

HTP's solution is spot on - THANKS!
(I didn't even have to log out/in, as soon as I restarted xfdesktop, the desktop came right back.)

All times are GMT -5. The time now is 02:34 PM.