-   Linux - Desktop (
-   -   XBMC Live 10.1 and ATI Radeon X300 (

fmr 09-12-2011 09:48 AM

XBMC Live 10.1 and ATI Radeon X300
Hi, I'm trying different things to set up my HTPC with XBMC. The machine uses a ATI Radeon X300 PCI Express card (quite an old thing).

First, I tried OpenSuSE 11.3, of which I already had the DVD. The OS works fine, but when trying to run XBMC, it fails because XBMC needs GL support. So off I go to to find a driver. In the sidebar:
  1. Desktop Graphics
  2. Radeon X Series
  3. Radeon X3xx Series
  4. Linux x86
  5. Click "View results"
I went to runlevel 3, and did

which failed. So I did

./ --listpkg
to see which distros are supported, and it seems that SuSE is only supported up to 11.1

The next thing I tried, is to download XBMC Live 10.1, which runs neatly on almost all conputers with or without installing it to the hard drive. It is based on Ubuntu Lucid. I installed it, and it works, but XBMC runs with a framerate of Deus Ex 3 on a Commadore 64 :P Like 1 frame every 10 seconds or so.

Any ideas? It seems that I need a better driver, but where and how?

I forgot to add:
CPU usage and Memory usage are both at about 1%, and temperature is 35 Celcius, so it has to be the graphics card.
Also, when I go to a tty (CTRL+ALT+F1; which responds just fine), I see the following error just before the login prompt:

fb: conflicting fb hw usage radeondrmfb generic driver

TobiSGD 09-12-2011 11:44 AM

The X300 should run fine with the open source radeon drivers, but since the X300 is an R300-family chip it needs firmware to run OpenGL (and I think video acceleration, but not sure about that). I don't know if that firmware is integrated in openSuse, in Debian it is in the package firmware-linux-nonfree, so if you can't find it in Suse you may be able to extract it there.

fmr 09-12-2011 02:26 PM

Currently installed is still the XBMC Live 10.1 using Ubuntu Lucid (That's a Debian distro, right?) I have heard about the firmware-linux-nonfree package. However, the package is not in the Ubuntu Lucid repository. There is however, a package named linux-firmware-nonfree. Is there any difference? I installed it, and see no difference. Should I reinstall the driver, too? If so, which package contains the driver?

Excuse my ignorance, but in my two years of using linux I've only used Nvidia drivers and cards, and they work hassle free every time.

TobiSGD 09-12-2011 02:34 PM

The driver should be installed by default, and I think that Ubuntu just named the package different. Astonishingly I am not able to find the package in the Ubuntu package search site, so I can't investigate further. It may be possible that you have to reboot after installing the firmware, did you try that.

fmr 09-13-2011 06:30 AM

Here it is:

I did restart, which made no difference.

What is the driver called? Would purging it and installing again help?

TobiSGD 09-13-2011 11:13 AM


Originally Posted by fmr (Post 4470505)
What is the driver called? Would purging it and installing again help?
Just give it a try.

fmr 09-13-2011 12:34 PM

Problem solved!
Thank you for your time and help!

Although I have not tried your latest suggestion, I have fixed the problem by removing

from the boot option and adding

for good measure.

I'm not sure which fixed it (probably removing vesafb), but it works now.

Kind Regards

All times are GMT -5. The time now is 03:18 PM.