-   Linux - Desktop (
-   -   x0vncserver over ssh tunnel connection issues (

fault-tolerant 10-08-2013 12:41 AM

x0vncserver over ssh tunnel connection issues
My setup: an embedded ubuntu solution running Xorg only (no window managers) and a graphical application. x0vncserver is installed, started from .xsession file in the following way:

x0vncserver -securitytypes=none -localhost &

I used to have some program to access this server from a windows machine, it was initiating an ssh connection and then automatically ran a standard vnc client. Everything used to work fine, even though I vaguely remember having trouble to connect in the most common way with putty tunnel and a vnc client before this piece of software was found.

The windows computer has crashed, the linux server is still alive with the same configuration. I tried the putty tunneling method again, with various vnc clients and so on... Kept asking me for password! Also, giving me all kind of stupid errors (depending on the client type). Couldn't find the same software I used to work with... Anyway, now the RealVNC viewer keeps saying "Too many security failures". I agree that the server might have some timeouts implemented and that my games triggered the protection, but I can't find any way of resetting it. Once in a while it asks me for a password again, and even if I press "cancel" next time it is at the same "too many security failures" message.

When I start the server without the localhost restriction (remove the "-locallhost"), I can easily connect remotely without tunneling and without password.

Any ideas for me?

mostlyharmless 10-16-2013 11:28 AM

Welcome to LQ.

I don't know about your main problem, but I suppose you could uninstall and reinstall RealVNC and all its data to get it to reset...assuming that it is the problem. Perhaps if you post the exact other "stupid" VNC errors it will be illuminating.

You could also change your configuration by closing all ports except ssh to the outside, instead of using localhost. You're tunneling anyway.

fault-tolerant 10-20-2013 11:18 AM

No logic in this, but reinstalling openssh-server solved the problem. Makes no sense, since I didn't touch this machine at all... except for an update? Well, anyhow - reinstalled the ssh server.

All times are GMT -5. The time now is 10:24 PM.