-   Linux - Desktop (
-   -   USB mouse showing as keyboard (

Wornout 08-10-2006 09:37 AM

USB mouse showing as keyboard
I have a copperhead mouse that I can't get running. Normally I can search and figure this out but apparently everybody else has theres The problem is that the mouse is showing up as a keyboard and a mouse. I looked at xmodmap -pp output and it says I should have 11 buttons. Various different configurations always end up saying that there should be 11 buttons instead of 7 when i run
the xmodmap -e "pointer = 1 2 3 6 7 4 5" command.

I have never dealt with anything like this before so I have no idea
what to do.Any suggestions?

I'm in slamd64 and this is my only usb device.

Wornout 08-10-2006 02:21 PM

Was able to find the answer. Apparently the newer versions of xorg assume 11 buttons. So all I had to do was configure x correctly.

If you have this problem try this:

Option "CorePointer"
Option "Device" "/dev/mouse"
Option "Protocol" "Auto"
Option "Buttons" "7"
Option "ZAxisMapping""4 5"
Option "ButtonMapping"" 1 2 3 6 7"
Option "Resolution" "2000"
Option "Emulate3Buttons" "off"
I dont know if it has to be exactly this way but it works for me.
Still can't figure out why the bootloader says I have a copperhead mouse and a copperhead keyboard? Guess it doesn't matter. Everything works now.

Chromezero 08-10-2006 04:11 PM

Thanks for posting a fix. I was considering purchasing one of these and the thread title caught my eye.

All times are GMT -5. The time now is 08:00 AM.