-   Linux - Desktop (
-   -   upgraded to 10.10 .Rec' error message "invalid RT chipset detected" (

davefrank 11-25-2010 06:56 PM

upgraded to 10.10 .Rec' error message "invalid RT chipset detected"
I loaded 10.10 and opted for the dual boot option.
The previous 10.04 i retained in case of problems.
I encounterd the "invalid RT chipset" error.
I was also unable to configure the sound card device (/dev/dsp.
I was also not given the option of rebooting my previous version ie 10.04.
The only version available to select in the grub menu was 10.10. together with its recovery and memory check options.
I selected the option to install along side the existing version, and on attempting to re-install 10.04 noticed that 10.04 was still present within its own partition but i was unable to access it.
Both versions were installed from a purchased disc that accompanied the "Linux format"magazine.
I hope this is enough info.
Regards Davefrank.
Ps Linux is a new and exiciting venture for me.
Having spent years under the microsoft brolly.

DaneM 11-26-2010 04:29 AM

It seems like you have more than one issue going on here. Let's tackle them one-at-a-time. First, your sound card problem. Which chipset do you have as your audio device? We can easily determine this by typing, 'sudo lspci' (no quotes) and posting it to this thread. Please use the [*CODE]texttexttext[/CODE] tags around the output to make your post easy to read. Be sure to remove the '*' from the first 'CODE' so that it will be used as tags, rather than showing up like text (like I want it to at the moment, for the purpose of showing you what to type).

Once we get one problem solved (or on its way to being solved), we can tackle your GRUB boot menu problem.

davefrank 11-26-2010 07:05 AM

Thanks for prompt response:
The chipset is:

SiS AC 97 sound controller (Rev a0)


DaneM 11-27-2010 05:04 AM

What is the make and model of your computer and motherboard (if your computer is not a brand-name)? I found a post that suggests that this could be a problem with needing a BIOS update for your motherboard. Here is the reference:


DaneM 11-27-2010 05:07 AM

Also, the below link suggests that you "try to open sound panel and enable sorround channel, keep it high and try
to open a sound file!"

I hope that helps.


davefrank 12-01-2010 04:38 PM

Hello Dane
The sound problem is now resolved and i decided to reinstall 10.04 mounting on the entire disc with a single partition
The error message has now cleared.
A futher problem i have been trying to resolve is that Synaptic manager appears to install a package "Aldo"
Which is a morse code training distro but when i view "Installed software" its not present on the menu.
I have search various headings,i have tried removing and reinstalling but with out success.

Any thoughts

DaneM 12-05-2010 09:45 AM

To find out if a package is installed, you can try this in the command line:


dpkg-query --status aldo
If you want to search among the packages that currently ARE installed, try this:


dpkg-query --search aldo | less
This will list all packages that have "aldo" in their descriptions or names. The '| less' part makes it show them in a scrollable list. Try typing 'man dpkg-query' and 'man less' to get more information on these commands.

I'm glad you worked out your sound problem.

All times are GMT -5. The time now is 10:34 PM.