-   Linux - Desktop (
-   -   Ubuntu 12.04.1 Strange Issues (

jsteinberg 11-04-2012 11:41 AM

Ubuntu 12.04.1 Strange Issues
My computer started to not restore from suspend successfully. When I would hit the keyboard the monitors would turn on, and it would just show the cursor against a black background.
The cursor was responsive, but nothing else did anything. I hit ctrl+alt+F2 to get back to the CLI and was presented with a login prompt. When I enter my username, however, I would get
two I/O errors for /dev/sdc (which is the SSD system drive).

Then doing a hard reboot had mixed results:

- Sometimes it would get to the point it starts to load the GUI (just a solid purple background screen with no cursor/etc.)
- Sometimes it would get to the login screen and then freeze again at some random point afterwards, but always within a couple of hours or so
- Also, when it would go to suspend, it would almost always freeze

Occasionally, grub would also be corrupted and it would just give me some sort of file not found error when it tried to boot the OS. Using the live cd to do re-install grub fixed this problem when it would occur.

After a while of this, grub was corrupted again and I went into the live cd and tried to run SMART on the harddrive and it gave an error (not a SMART error I don't think, it was like it couldn't write to the drive to test it or something like that when it tried to start the test).
Then shortly thereafter, the drive wouldn't even show up from the livecd (although it never disappeared from the bio).

I bought a new harddrive (Samsung 830 128GB SSD) and tried to re-install. The first time it gave an I/O error when I tried to install, but I rebooted and the install went through without a hitch.
But, shortly thereafter, I had the same issues start and now I'm at the point where the new drive is not showing up in the live cd either.

Does anyone have any idea what could possibly be going on here?
I'm not sure what extra information I can post, but let me know and I can try to get whatever I can (keeping in mind I may not be able to get to the installed OS to run dmesg, etc.)

Here are my system specs:

ASRock x58 Extreme6 (BIOS v2.67)
Core i7 950
12 GB DDR3 1066 (3x 4GB in triple-channel configuration)
128 SSD Samsung 830 (original drive was a 64GB OCZ SSD)
500 GB WD Caviar Black
1 TB WD Caviar Black
nVidia GTX 460 (three monitors configured through the Matrox TripleHead2Go Digital with a custom xorg.conf which I have used for years with various distros/versions without issue)
LG Blueray Burner
LG DVD Burner
Logitech K800 Wireless keyboard
Logitech wireless mouse

It's running a stock Ubuntu 12.04.1 (64 bit) with the latest kernel from the official repo, the nvidia binary driver, and some changes to optimize for ssd (TRIM activated, swappiness to 0, /tmp to tmpfs, mount system drive as noatime,nodiratime,discard, and other common optimizations).

Thanks in advance for any help!

islandBilly 07-21-2013 05:27 PM

think I have the same problem
I have a laptop running 12.04 live from a usb stick, and twice now it has gone into the black screen with a cursor showing, which eventually becomes unresponsive. I did not suspend, but it simply went into screen-saver mode while I was away. I wish someone had responded to this original question six months ago so I would know what, if anything, to do. A hard reboot is all that works. I have lost some important (to me) writing this way.

yancek 07-21-2013 08:33 PM


I have a laptop running 12.04 live from a usb stick, and twice now it has gone into the black screen with a cursor showing
When you boot? when you are just using the system?


went into screen-saver mode while I was away.
Does that mean it locks and you have to enter a password to get back, or does that not work either? You can set it not to lock in System Settings by clicking the Screen icon and setting Lock to off. If you are actually using Ubuntu as a Live CD on a usb as you state, then it doesn't matter as that is a read-only filesystem and any changes will be lost on reboot, unless it is a persistent install.

All times are GMT -5. The time now is 11:38 AM.