-   Linux - Desktop (
-   -   Ubuntu 10.04 won't resolve DNS from Windows 2003 Server (

billinja 08-21-2010 05:27 AM

Ubuntu 10.04 won't resolve DNS from Windows 2003 Server
Morning all. In order to expand my knowledge for my job, I'm building a test lab at home using a Windows 2003 Active Directory, and wanted to have my Ubuntu boxes (10.04 server/desktop) resolve local, and external names via the Windows DNS. (NOTE: DNS resolution in Windows works properly)

As it stands, my router's DHCP server is dishing out my local DNS server's IP as primary, and my router's internal DNS as secondary. This brings us to my first problem.

1. Ubuntu picks up a DHCP address, but not the correct order for DNS. Actually, in the /etc/resolv.conf it only shows the router's address for DNS. I thought maybe this was a lease issue since I had just made the change to DHCP to include the new DNS, and wasn't sure how to force a renew in Ubuntu. To try to help, I modified my connection to get the address from DHCP, but use static DNS entries. No big deal, but a little annoying.

So then, once the server IP was reflected as the primary, I used NSLOOKUP to try to resolve an internal name. This gave me the next problem.

2. An error connecting to the primary server. The error message was as follows:

ERROR: Got SERVFAIL reply from x.x.x.x, trying next server (where x.x.x.x is my Windows DNS server's ip)

I then thought that maybe I needed the Ubuntu system to know what x.x.x.x was, and added it, and my domain's ip (the ip that resolves when you ping <mydomain>.com) to the /etc/HOSTS file, which didn't help.

I've done some pretty extensive Google searching, and have found nothing directly relating to my issue. Maybe it's just really early on a Saturday morning, and my search skills are weak, but I decided to post here, because its where I've had the few other issues I've experienced solved in a very short time.

So, I hope someone out there knows the solution for my pain, and thank you all in advance for reading/sharing your knowledge.

paulsm4 08-21-2010 10:41 PM

Hi -

It sounds like both problems are probably related - you should be able to get everything working with one solution.

Look here:
<= there are a couple of good suggestions here

This is a bit older ... but it has a LOT of detail:

In any case, please post back. Let us know what worked (if it worked), and let us know what you tried and how it failed (so we can help you get it working).

Good luck .. PSM

The original series, TNG, or one of the other variants? Or ALL of 'em ;)?

All times are GMT -5. The time now is 12:52 AM.