-   Linux - Desktop (
-   -   system tray goes missing on starting XFCE (

waddles 09-14-2012 04:15 AM

system tray goes missing on starting XFCE
I am getting these messages on booting:
PyOS_InputHook is not available...
Failed to initialize killswitch...
error: No system tray detected on this system
Then on starting XFCE I get a HPLIP Status Service dialog box with this message:
No system tray detected on this system, Unable to start. And asked to double click on my selection of which there is none so I click on default.

This just started for the first time after loosing the tool bar (which I keep at the bottom of the screen) since March of 2011. I tried running hp-check -r but it seems to hang or is just taking way tooooo much time. I learned that "time.sleep(1.0)" has been changed by some but don't know if this is an official workaround.
I am getting close to tossing this HP Deskjet 1000 due to the crappy support given by HP so hopefully someone has a good suggestion so I don't have to go get an epson.

SecretCode 09-15-2012 01:12 PM

What OS, what version of the OS, what version of Xfce?

Have you been missing the default panel at the bottom of the screen since March 2011? Have you tried adding it back and adding "Notification Area" to the panel? (Notification Area is what most linux DEs call the system tray.)

SecretCode 09-15-2012 01:55 PM

If you can't get the system tray back this might help: [SOLVED] Xfce 4.6.2: After Log Out, No System Tray/Task Bar on Restart

waddles 09-16-2012 02:03 AM

Slackware 13.37 and XFCE is ver.4.6.2.
Rarely the toolbar with pager etc. goes missing but can get that back no problem after March 2011.
Yes that happened just before, and do have Notification area.
No, that is different from system tray which is related to HPLIP.

waddles 09-19-2012 02:09 AM

system tray goes missing on starting XFCE
I am concluding this thread as I now have hp-systray back.
I do NOT know what caused it to disappear OR return.
In bringing back my desktop, I had to restart my toolbar by creating a run time box and entering: xfce4-panel

I did find the following on the web for getting back the system tray:
1) Ctrl-Alt-Backspace to kill your X session
2) rm -rf $HOME/.cache
mv it to be more safe.
1) clean out the .cach directory
.kde.bak and
.kdevduchain just on general principles.
2) restart X and good to go
I did not try it.

But found this as a consequence of starting hplip:
Usage: hp-systray [OPTIONS]

Use Qt4: --qt4 (Default)
Set the logging level: -l<level> or --logging=<level>
<level>: none, info*, error, warn, debug (*default)
Run in debug mode: -g (same as option: -ldebug)
This help information: -h or --help
Startup if no hplip CUPS queues present -x or --force-startup

Would suggest trying the -x option if desperate.

All times are GMT -5. The time now is 05:41 AM.