-   Linux - Desktop (
-   -   Sound doesn't work until KDE is started (

sisk 11-07-2012 05:16 PM

Sound doesn't work until KDE is started
I have numerous DEs on my system and primarily use Fluxbox. However on a new system I've found that for some reason sound does not work for most of my programs until I have logged into KDE. There are a few exceptions, by which I can verify that Alsa is working correctly. I can log into KDE and then log back out and into Fluxbox and everything works fine, but if I try to log into Fluxbox first I get no audio. Clearly there's something initializing when KDE starts, but I can't for the life of me figure out what it might be. Does anyone know that it could be and, more importantly, what command I would need to pass to make it initialize when I log into a different desktop environment?

teckk 11-07-2012 08:19 PM

Is everything turned up in alsamixer?
What mixer control are you using with fluxbox? Gnome alsa mixer works well.
You'll need to read how to keep alsamixer settings on reboot for your flavor of linux.
I suspect that KDE does that for you.

sisk 11-08-2012 09:27 AM

I usually use alsamixer with Fluxbox and I've checked it. All of the volume settings are right where they should be. As I said, some programs (notably MPlayer) work as expected. Other programs don't have any sound at all. The two that really bring the issue to a head that don't work are Amarok and Firestorm. Firestorm in particular is strange because I can hear the environmental sounds (birds chirping, wind blowing, that sort of thing) and people's gestures but not the music from whatever club I happen to be at in Second Life until I've initialized KDE. The rest of my programs are hit or miss, but those are the three important ones (relatively speaking, of course).

All times are GMT -5. The time now is 12:05 PM.