-   Linux - Desktop (
-   -   slackware x in asus laptop (

adhikari 09-26-2006 08:41 PM

slackware x in asus laptop
I just purchased this new ASUS A6U laptop and installed slackware 10.2 on it as a full install. This is my 4th try but everytime when i go to X-win (kde) and log out or while i am in kde if i try getting to other terminals with Cntrl + Alt + f3 etc the screen just goes blank and I can't see or do anything even in the terminal where the xwin was intally started (suspect it is 7).

But if i login to root from terminal 6 (this is still all blank so I am typing without seeing anything on the screen) and issue shutdown -r now it works. That means the system is still running in the background and its just the screens on all terminals including xwin one are blank.

Any suggestions in fixing this? I would imagine if the Sis Graphic card was incompatible it wouldn't start the xwin in the first place...

kernel version is 2.6 and modules 2.6 installed with gcc for that version of kernel as well. (initally used test26.a from slackware cd as a kernel image and installed modules from disk 2 and the gcc etc from "testing" folder in disk 3 of installation disks)

thanks in advance....

fozner 09-27-2006 12:18 AM

I don't know much about what X does when you switch modes. Have you tried CTRL-ALT-[+] and CTRL-ALT-[-] combinations X uses to change screen resolution? Maybe it's going into a mode the laptop screen can't "see". You can also plug it into an external monitor and maybe see the screen again. Then you can pay with modelines or try commenting out the horizontal and vertical refresh and letting it auto detect.

adhikari 09-27-2006 08:40 PM

didn't work
Thanks for the suggestion. I tried that but didn't work. I changed the lilo setting to mode "normal" and others really low level ones as well but made no difference.

If anyone has any other suggestions, let me know.

fozner 09-28-2006 12:17 PM

Most laptops have a VGA plug in the back where you can plug them in to an external monitor. This is a quick way to narrow down whether we are dealing with a simple mode change or something more video card related.

gkiagia 09-30-2006 03:45 AM

This might be an incompatibility between the X graphics driver and the vesafb driver. I think that if you remove the vga=xxxx option in lilo, vesafb will be disabled (at least that happens in suse). Try it.

All times are GMT -5. The time now is 07:03 PM.