LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (https://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Second monitor won't wake up after sleep (https://www.linuxquestions.org/questions/linux-desktop-74/second-monitor-wont-wake-up-after-sleep-4175647194/)

burkina76 01-29-2019 02:58 AM

Second monitor won't wake up after sleep
 
Hi all,

I have UBUNTU 18.04.01 on a Dell Precision 3620, connected to two identical Dell monitors (not mirroring), both connected via DP. The adopted graphic drivers are NVIDIA 390.87.

When the two monitors resume from sleeping, it often happens that one of the two (always the same) remains black. Sometimes I can make it awake by repeatedly turning off/on both monitors, but in many cases the only solution is to log out.

I did several tests, and updated both the operating system and the NVIDIA drivers in the meantime, but this very annoying issue does not disappear.

Any clues?

Thanks,

Stefano

mrmazda 01-29-2019 06:15 PM

Is all this hardware recently acquired? Or is this just a new problem created by software upgrade or hardware component replacement. One of my Dell displays, d2913wm, is really picky about power up/power down/sleep event timing. I got Dell to replace the first month I had it, then Dell blamed my trouble on the Dell PC being "out of support" and signed off trying to help. It wouldn't surprise me of your problem is actually display firmware. Does Ctrl-Alt-F[2-6] then Alt-F1, Alt-F7 or Alt-F8 awaken the sleeper? Do BIOS or firmware updates exist for any of your Dells? Are your displays configured to use DisplayPort v1.2 or newer? If they are, try switching that off. If not, try turning it on.

burkina76 01-30-2019 01:55 AM

Hi mrmazda,

thank for your reply.

No, this problem is a long-standing issue, that appeared also when the second monitor was different and connected with HDMI instead of DP. In the meantime, I updated the operating system, the NVIDIA drivers, the BIOS, changed the monitor, the connecting cable....
Ctrl-Alt-F does awake the other monitor, but moving back to the original screen makes it sleep again.

My guess is that it is a NVIDIA-related issue.

Stefano

mrmazda 01-30-2019 02:47 AM

Have you tried running xrandr in the awake display?

burkina76 01-30-2019 02:58 AM

Yes, I've tried, the only thing I can get is to awake the second display as a mirror, maybe I'm not using the right command.

Stefano


All times are GMT -5. The time now is 03:47 PM.