-   Linux - Desktop (
-   -   rsync problem. Lucid Lynx backing up to Samsung external drive (

karmicnoob 10-19-2010 08:21 AM

rsync problem. Lucid Lynx backing up to Samsung external drive
On two occasions I've tried to back up my home folder using;

rsync -av --progress /home/michael /media/Backup

and after copying several files it gets to a virtualbox vdi of XP and stops, giving the following;

3235938816 100% 8.56MB/s 0:06:00 (xfer#41, to-check=1002/1113)
4290052096 72% 6.82MB/s 0:03:51
rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32)
rsync: connection unexpectedly closed (820 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(601) [sender=3.0.7]

I've found others with this problem but no solution. Any tips appreciated.

AlucardZero 10-19-2010 08:45 AM

Disk full on the other side?

Network interruption?

karmicnoob 10-20-2010 03:49 PM

Plenty of disc room and the network connection was fine. I tried twice and it snagged at that exact same point, 72% into backing up the Windows XP vdi. I removed the virtual disc and it ran with no hitches whatsoever.

Someone suggested running the command as root might have taken care of the problem so I might try that after reinstalling the virtual XP.

AlucardZero 10-20-2010 04:29 PM

failing disks? file system with errors?

karmicnoob 10-23-2010 12:15 PM

I'm not sure how to check for either of those possibilities but I've had no other symptoms besides the inability to back up the Windows XP vdi.

Skaperen 10-26-2010 10:05 AM

Looks like rsync is hitting a 4GB limit. Is this a 32 bit system? How large is the original file?

karmicnoob 10-27-2010 03:44 AM

That could be it, though I can't remember the size of the XP vdi ( I removed it to be able to back up home) I'm more certain it was a problem with the external drive as it repeated this behavior on another computer.

All times are GMT -5. The time now is 11:35 AM.