-   Linux - Desktop (
-   -   Recover NTFS partition (

jshellman 11-14-2006 12:07 PM

Recover NTFS partition
I had Windows XP Pro (32 bit) installed on one drive. I installed CentOS 4.4 on a different drive. I can no longer access the partition on the winxppro32 drive. fdisk still shows it there with a code 7 (HPFS/NTFS) partition. But if I try to mount it, I get:

# mount /dev/sdb1 /mnt/win32
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
or too many mounted file systems

I have another disk with ntfs partitions on it (it is a windows xp pro 64 bit install) and they mount fine.

And now, if boot into the winxppro 64 bit install, I can't see the data in the winxppro32 partition. It asks if I want to format it if I click on it in Explorer.

Any ideas on how I can mount this thing and get the data? It sees like it should still be there.

I think I did incorrectly run grub-install /dev/hda and grub-install /dev/hda1. Could that have caused this problem?

I've seen some people talk about fixing grub install clobbering with windows recovery, but that doesn't help me because windows recovery says it doesn't find a windows installation on the disk, or maybe it said it couldn't find a disk at all.

I don't care about getting it bootable, but I do want access to the data.

I'm on a dual Opteron machine running centos 4.4 x64.


Vincent_Vega 11-14-2006 12:27 PM

For a real quick fix, try booting from a Knoppix CD. That will give you full support of that NTFS drive. If it's readable, Knoppix will read it. Then you could start copying over what you wanted to salvage.
If Knoppix can't read it, I would say you're screwed.

jshellman 11-15-2006 07:44 AM

Fixed it
Created Knoppix boot CD and used testdisk to rewrite boot sector or something on the partition itself and then it was accessible.

I had tried using testdisk from my centos installation but it didn't work--must be busted for my setup (centos 4.4 x64--tried to build from source rpm).


All times are GMT -5. The time now is 06:29 AM.