-   Linux - Desktop (
-   -   Re-installing NVidia video driver (

williepabon 03-25-2012 04:00 PM

Re-installing NVidia video driver
I recently upgraded my kernel from Ubuntu 10.04 to 11.10, but after doing that I lost my Nvidia GE Force 8400 GS driver. Well, I thought, I needed to re-install it like I did on 10.04, which I did with the commands below:


sudo apt-get --purge remove nvidia-current
sudo apt-get --purge autoremove
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get -y install nvidia-current

Well, it didn't work, even though it appeared that the installation was successful. I still get the vga compatible driver, as shown.


williepabon@WP-WrkStation:~$ sudo lshw -C video
[sudo] password for williepabon:
      description: VGA compatible controller
      product: nVidia Corporation
      vendor: nVidia Corporation
      physical id: 0
      bus info: pci@0000:05:00.0
      version: a2
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list rom
      configuration: driver=nouveau latency=0
      resources: irq:16 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:cc80(size=128) memory:dfc00000-dfc7ffff

Someone suggested to download the latest driver directly from the Nvidia site, which I did. It comes as a shell script that needs to be run on terminal as root. When I tried this, I got the following error:
ERROR: You appear to be running an X server; please exit X before installing.
My experience with Ubuntu is not enough to do much work in command mode (unless I am very well guided). I learned how to run a shell script, and I got the message as explained above. But I don't know how to stop the X server and turn it on again. And, I'm not sure if after installing the driver using the shell script, everything will work automatically as it does when you install using the Ubuntu repos (as I did when I had the 10.04 kernel). Thanks for the help.

williepabon 03-25-2012 07:59 PM

Problem solved. Removed the driver again and did a re-install using the hardware Drivers sub-menu, chose the recommended Nvidia driver from the list, and clicked activate. That did it.

All times are GMT -5. The time now is 07:20 AM.