-   Linux - Desktop (
-   -   Problems with XFCE (bug?) (

CWood 04-13-2013 07:27 AM

Problems with XFCE (bug?)
Just now, I had a problem with XFCE (4, I think. Came with Slackware 14.0, with the 3.7.1 kernel, if that helps). The top pane came down, as usual when I mouse over it, but would not disappear again, when I moved off.

I restarted the X server, and lo and behold, all window decorations are gone, the cursor appears as a cross, I can open windows but not close, minimize, or change the order of them, or move them for that matter, which means I'm writing this with a Thunar session covering the top right-hand corner of the browser, the top and bottom panes appear behind windows, I have no idea how to close anything, and am wondering how in the world I'm going to carry on working like this.

I know it's a bug in XFCE, at least I believe it is, however right now I don't have the time to sign up to report it, as I need to get my coursework done.

I should probably add, however, that I tried restarting X again, and it didn't work, and also tried restarting the computer completely, which also didn't work. As such, I have absolutely no idea how to continue.

Any assistance would be greatly appreciated.


Emerson 04-13-2013 08:53 AM

Create another user, log in as this new user, does the problem persist?

CWood 04-13-2013 08:57 AM

The problem seems to disappear, on using a new user. I just tried it as root (I know you shouldn't but it was a quick test), and other than having to fiddle with xrandr to get my second monitor working, there was no issue.

Could the 2 monitors be causing this, I wonder?

camorri 04-13-2013 09:05 AM

Are you running compiz? I had window decorations problems with 13.37 and compiz, and non stock kernels.


I should probably add, however, that I tried restarting X again, and it didn't work, and also tried restarting the computer completely, which also didn't work. As such, I have absolutely no idea how to continue.
How were you restarting the x-server ? Usually ctrl + alt + backspace will work, if keyboard keystrokes are being seen by the system.

Can you elaborate on the full restart that didn't work?

CWood 04-13-2013 09:09 AM

As far as I'm aware, I'm not running Compiz, however I'm not too sure how to check that. As for restarting the X server, I logged back out to the terminal, and ran startx again, getting the above symptoms.

As for the restart, I went to the user menu (top right hand corner), hit logout, and hit restart. I started the X server up again, and the symptoms didn't change.

camorri 04-13-2013 09:28 AM

Compiz is not installed with a full install, you have to install it with slackbuilds ( or sbopkg ) as an extra application. You would know if you had done that. To check if its installed, the following command on my system shows the compiz... and some of the other associated packages.


ls /var/log/packages | grep compiz
-rw-r--r-- 1 root root 9585 May 10 2011 compiz-0.8.8-x86_64-1
-rw-r--r-- 1 root root 1088 Jan 21 11:12 compiz-bcop-0.8.8-x86_64-1_SBo
-rw-r--r-- 1 root root 7046 Jan 21 11:17 compiz-plugins-extra-0.8.8-x86_64-1_SBo
-rw-r--r-- 1 root root 7503 Jan 21 11:16 compiz-plugins-main-0.8.8-x86_64-1_SBo
-rw-r--r-- 1 root root 5715 Jan 21 11:18 compiz-plugins-unsupported-0.8.8-x86_64-1_SBo
-rw-r--r-- 1 root root 1224 Jan 22 09:34 compizconfig-backend-kconfig4-0.8.8-x86_64-1_SBo
-rw-r--r-- 1 root root 1226 Jan 21 11:15 compizconfig-python-0.8.4-x86_64-1_SBo
-rw-r--r-- 1 root root 1508 Jan 21 11:15 libcompizconfig-0.8.8-x86_64-1_SBo
FWIW, you can do a full restart with the following keystrokes, in the event the normal gui buttons don't want to work.

Hold down alt + sysrq and one at a time type r e i s u b . Only use this if normal ways of restarting do not work. You can try it some time when nothing else is going on.

Did you do a full install? Have you seen the problem with a stock kernel?

CWood 04-13-2013 09:35 AM

Okay, I definitely don't remember installing compiz. That can be ruled out.

As for the REISUB thing, I thought that was for a kernel panic? If the GUI didn't work, I'd change to term1, and Ctrl-C the X server, and start again that way, personally (though that might not be as clean...)

As for the installation, the box started out (a while ago, now) on stock 14.0, but then I upgraded to slackware-current, with the 3.7.1 kernel. I noticed the issue with the top panel not disappearing a long time ago, but I never had an issue like this before.

camorri 04-13-2013 09:51 AM

Ahhh, you are running current. It might be worth you spending a few minutes to read through this thread


Current is bleeding edge, and users are expected to see some problems. I run stable release and have not seen this typr of problem, other than on a non stock kernel, and compiz. This is not the case here.

Emerson 04-13-2013 10:36 AM

Simple things first, back up Xfce conf in your home (rename it) and try again.

CWood 04-13-2013 11:10 AM

I'm using XFCE 4.10. Which files do I need to back up? I've got a whole plethora of them in ~/.config

Emerson 04-13-2013 12:29 PM

I'd rename autostart and xfce4 and see what happens.

CWood 04-14-2013 04:10 AM

No joy on renaming autostart and xfce4. All that really happened was that I had to reselect what panels I want to have (default or 1), run xrandr manually, and open the browser manually.

Virtual desktops are still not working, the mouse still shows up as a cross in some places, the whole thing looks like a mashup between XFCE and Windows 95, and I don't know what to make of any of this. As soon as we find a way around this, I'm going to sign up and report this as an XFCE bug.

goumba 04-14-2013 08:26 AM


Originally Posted by CWood (Post 4931219)
the whole thing looks like a mashup between XFCE and Windows 95

I can't speak for the rest of your issues, but this reads like a theming issue. Try going to appearance, change themes, and see if it persists.

CWood 04-14-2013 11:49 AM

Would that I could. Can't access a whole lot of much with Firefox in the way... I'm starting to feel I'm going to have to reinstall from scratch... Ah well

CWood 04-15-2013 02:28 AM

Okay, now it's very, very annoying. Firefox is half way off the screen. Found out I can drag tabs to the other screen and spawn a new window, but only for a certain amount of tabs. I can't get any further. It also won't refocus the keyboard on the new window, making the new browser less than useless. This is getting to be a real show-stopper now.

Just had a thought, while typing this, actually. Last time something like this happened was at the beginning of last year, I think, when I had just upgraded to Ubuntu 12.04. It went nuts, in the XWM, and would not function, and as it turned out, I had some defective RAM. Maybe time to fish out Memtest, and see what that brings up, because I really can't believe a project as mature as XFCE could fail so catastrophically, in a public release version, even if it hasn't been on the market as long as its predecessors.

All times are GMT -5. The time now is 06:34 AM.